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Unable to install OpenEdge Service Pack or (re) install OpenEdge Error 0x80040303

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TitleUnable to install OpenEdge Service Pack or (re) install OpenEdge Error 0x80040303
URL Name000053224
Article Number000121078
EnvironmentProduct: OpenEdge
Version: 11.x
OS: Windows
Question/Problem Description
Unable to install an OpenEdge Service Pack  or (re) install OpenEdge on Windows with Error 0x80040303
Unhandled exception when trying to install an Service pack on Windows
 
Steps to Reproduce
Clarifying Information
After a failed installation of an OpenEdge Service Pack, the existing OpenEdge installation was uninstalled and the new installation of OpenEdge then fails as well
Installs are run with Administrators privilege
Error MessageUnhandled exception
Error Number: 0x80040303

Description:
Setup will now terminate.
Defect Number
Enhancement Number
Cause
Installshield files used for the OpenEdge installation are corrupt.
Resolution
0.  Verify the MD5 Signature of the Service Pack

This information is found on the Electronic Download site, for example 11.3.2 MD5: ef8de76c94c191cdd8f089be2ff04700 
Otherwise download the install media again and re-verify the MD5 Signature.
    1.  Delete the following InstallShield folders:

    The InstallShield creates an archive of its installers under the Window's Program Files directory, in a folder labeled "InstallShield Installation Information".
    c:\Program Files (x86)\InstallShield Installation Information

    The folder name or GUID changes for each major release and platform. For example: The same OpenEdge version for Windows 32-bits and Windows 64-bits have a different GUID).​
    To find the correct GUID, take the command line from the Uninstall shortcut in the Start Menu of an existing installation.
    If OpenEdge shortcuts still exist, this information can be found in the Properties of: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\OpenEdge <version>\Uninstall OpenEdge.lnk
    • C:\Program Files (x86)\InstallShield Installation Information\{InstallGuid}
    • A failed install may still have Temporary files in: C:\Users\xxxxxxxx\AppData\Local\Temp\{}\{InstallGuid}\
      (where xxxxxxxx is the name of the Windows user that installed OpenEdge)
    • C:\ProgramData\Microsoft\Windows\Start Menu\Programs\OpenEdge <version>
    2.  Delete the following registry keys: 
    • HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{InstallGuid} 
    • HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Uninstall\{InstallGuid}
    • HKCU\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\{InstallGuid} 
    The registry keys related to the OpenEdge version under
    • HKLM\Software\SysWOW32\PSC
    • HKCU\Software\PSC
    For further information refer to Article  How to uninstall OpenEdge manually, what Windows Registry entries must be removed?    
     
    3.  Delete the following OpenEdge installation folders: 
    • %DLC%
    • %WRKDIR%
    • %OEM%
    • %OEMWRKDIR%
    4.  Re-install OpenEdge

    "Run as administrator" setup.exe from the install media to complete the installation
     
    Workaround
    Notes
    Keyword Phrase
    Last Modified Date11/20/2020 7:08 AM

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