Salesforce

What are the terminate options for the "terminateABLSession" REST API or OEJMX query?

« Go Back

Information

 
TitleWhat are the terminate options for the "terminateABLSession" REST API or OEJMX query?
URL NameDocumentation-on-the-terminateABLSession-JMX-query-is-missing
Article Number000204037
EnvironmentProduct: OpenEdge
Version: 11.7, 12.x
OS: All supported platforms
Other: Progress AppServer for OpenEdge, PASOE, OEJMX, REST API
Question/Problem Description
How do the terminateABLSession options affect managing MSAgents and their ABL sessions?

What are the terminate options used with terminateABLSession in a OEJMX query ?
{"O":"PASOE:type=OEManager,name=AgentManager","M":["terminateABLSession","<agentID>",<agentSessionID>,<terminateOption>]}

What are the terminate session options for the REST API DELETE call ?
DELETE /oemanager/applications/<abl-app-name>/agents/<agent-id|agent-pid>/sessions/<session-id>?terminateOpt=<terminate-opt>
Steps to Reproduce
Clarifying Information
The terminateABLSession OEJMX query and its equivalent REST API are an important mechanism for managing MSAgents and their ABL sessions.

OEJMX terminateABLSession or the DELETE API call is useful to manage memory leaks and other bad sessions (criteria for "bad" depends on the application session context).
 
Error Message
Defect NumberCONT-8122
Enhancement Number
Cause
This information was missing from the documentation.
Resolution

A documentation defect has been submitted to update the documentation with the following information.

The terminate options for the terminateABLSession OEJMX query which can also be used in the DELETE API call are:

  • 0 (Trappable stop):
    • ABL A Progress.Lang.StopError error is raised in the session. (soft/trappable stop), 
    • This can can caught by the application and dealt with appropriately. 
    • If not caught then a 500/Internal Server Error will be returned to the client.
  • 1 (Hard stop):
    • An untrappable/uncatchable stop is raised since standard ABL stop behaviour applies ((ie transactions undo etc). 
    • A 500/Internal Server Error will be returned to the client, roughly equivalent to `kill -9` on the session,
  • 2 (Complete request):
    • Any current request is allowed to finish and then the session is terminated.

 

Starting with OpenEdge 12.2.7 and 12.5, the following messages are written to the PASOE Agent log file when an ABL Session is terminated:

  • For terminate option 0: Admin initiated termination of ABL Session AS-<number> with option: STOP
  • For terminate option 1: Admin initiated termination of ABL Session AS-<number> with option: INTERRUPT
  • For terminate option 2: Admin initiated termination of ABL Session AS-<number> with option: FINISH
    Workaround
    Notes
    Keyword Phrase
    Last Modified Date11/26/2024 2:10 PM

    Powered by