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Cannot determine whether a StopError was raised from the terminateABLSession JMX query

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TitleCannot determine whether a StopError was raised from the terminateABLSession JMX query
URL Namecannot-determine-whether-a-stoperror-was-raised-from-the-terminateablsession-jmx-query
Article Number000204038
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: All supported platforms
Other: Progress AppServer for OpenEdge, PASOE, JMX
Question/Problem Description
Cannot determine whether a StopError was raised from the terminateABLSession JMX query.
 
Steps to Reproduce
Clarifying Information
When the {{terminateABLSession }} JMX query is called, a terminate option may be provided.

terminateABLSession JMX query:
{"O":"PASOE:type=OEManager,name=AgentManager","M":["terminateABLSession","<agentID>",<agentSessionID>,<terminateOption>]}

If this is 0, then the session is terminated with a trappable stop - a Progress.Lang.StopError is raised. This may be caught and dealt with by the application.

However, there is no way of knowing that this error was caused by the JMX query being called, and this makes it impossible to act upon that fact. So if an application wanted to catch stops, but allow this kind of stop to proceed, could not.
Error Message
Defect NumberOCTA-38237
Enhancement Number
Cause
The exact cause is not known at this time.
Resolution
Fixed version(s): OpenEdge 12.5
Workaround
Notes
Keyword Phrase
Last Modified Date10/23/2023 12:08 PM

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