Salesforce

terminateABLSession requests are not logged

« Go Back

Information

 
TitleterminateABLSession requests are not logged
URL Nameterminateablsession-requests-are-not-logged
Article Number000204035
EnvironmentProduct: OpenEdge
Version: All supported versions
OS: All supported platforms
Other: Progress AppServer for OpenEdge, PASOE
Question/Problem Description
terminateABLSession requests are not logged.

DELETE /oemanager/.../sessions/<session-id> HTTP requests are not logged.
 
Steps to Reproduce
Clarifying Information
terminateABLSession JMX query:
{"O":"PASOE:type=OEManager,name=AgentManager","M":["terminateABLSession","<agentID>",<agentSessionID>,<terminateOption>]}

DELETE session HTTP request:
DELETE /oemanager/applications/<abl-app-name>/agents/<agent-id|agent-pid>/sessions/<session-id>&terminateOpt=<terminate-opt>
Error Message
Defect NumberOCTA-38299 , OCTA-39471
Enhancement Number
Cause
The message was missing from the default logging.
Resolution

Upgrade to OpenEdge 12.2.7 or later 12.2.x release.
Upgrade to OpenEdge 12.5 or later.

Starting with OpenEdge 12.2.7 and 12.5, the following messages are written to the PASOE Agent log file when an ABL Session is terminated:

  • For terminate option 0: Admin initiated termination of ABL Session AS-<number> with option: STOP
  • For terminate option 1: Admin initiated termination of ABL Session AS-<number> with option: INTERRUPT
  • For terminate option 2: Admin initiated termination of ABL Session AS-<number> with option: FINISH


 

Workaround
Add the parameter “MSASAdmin:2” to agentLogEntryTypes.

An admin message is issued in the Agent log file.
Notes
Keyword Phrase
Last Modified Date11/26/2024 2:25 PM

Powered by