unix Permissions on source files and compiled files - Forum - Roundtable Community - Progress Community
 Forum

unix Permissions on source files and compiled files

This question has suggested answer(s)

How can I configure the unix permissions for source code saved and for compiled code generated via Roundtable? It does not seem to be using the umask settings for the root user.

I am using OE10.2B and Roundtable TSMS version 11.8.2 on a Windows client with a SunOS AppServer.

All Replies
  • Hi. The permissions are dictated by the appserver user as it does the writes to the workspace. Roundtable does not explicitly set permissions.

    Jeff Ledbetter
    Roundtable Software

    Jeff Ledbetter
    Product Architect | Roundtable Software

  • More detail for this (assuming an AppServer configuration):

    1. Code that is written from the repository will inherit the permissions of the owner of the AppServer. If traditional AppServer, this is the Broker Owner. For PASOE, this will the the user that is running the instance (via tcman) or the user specified with the -u option when created (with tcman).

    2. Code that is compiled on the server will also adhere to the above.

    3. When using the GUI client and a Samba share for the Workspace, saved and compiled code will inherit permissions of the Samba user.

    4. When using the plug-in client, the Workspace code is written by the AppServer so #1 above will apply.

    Jeff Ledbetter
    Product Architect | Roundtable Software

  • Thank you for your responses, Jeff!  That information is helpful.  We do have a GUI client and a Samba share and bash SHELL.  

    Here are the settings:

    In /etc/profile:  umask 022

    In /home/root/.profile: (we have no "umask" setting)

    In /etc/samba/samba.conf:

    - create mask = 0664

    - directory mask = 0775

    - force create mask = 0664

    - force directory mask = 0775

    The *source* code is being created with 664 settings, but the compiled code is being created with 666.

    I am not sure if samba log files help, but one log file has:

    [2020/01/02 20:15:49.121564,  0] ../lib/param/loadparm.c:1750(lpcfg_do_service_parameter)

     Ignoring unknown parameter "force directory mask"

    log.smbd has:

    [2020/01/03 06:56:27.528714,  0] ../source3/printing/print_standard.c:71(std_pcap_cache_reload)

     Unable to open printcap file /etc/printcap for read!

    These timestamps do not coincide with compilations done via my client version of Roundtable, so these messages might not be related to the permissions.

  • Several more things to note:

    - If I use notepad to create a text file and save it to the same r-code directory via a shared Samba drive, it is saved with 664 perms.

    - I was able to determine the umask setting for the root user on the AppServer is "0000" at the time the code is being compiled by using "INPUT THROUGH umask" command.

    - Our AdminServerPlugins.properties file has a blank value for the umask in the [PluginPolicy] section (i.e., "umask=").  Could this setting be why the umask setting is 0000 for the root user when our code is being compiled.

  • "Our AdminServerPlugins.properties file has a blank value for the umask in the [PluginPolicy] section (i.e., "umask=").  Could this setting be why the umask setting is 0000 for the root user when our code is being compiled."

    This Progress Kbase suggests so:

    knowledgebase.progress.com/.../000049331

    We usually recommend running the AppServer as a specific user.

    Jeff Ledbetter
    Product Architect | Roundtable Software

  • Thanks for the info, Jeff!  We will try running the AppServer as a different user.