Problem with deploying webservice - Forum - Technology Partner - Progress Community

Problem with deploying webservice

 Forum

Problem with deploying webservice

  • Hello List,

    Linux 9

    OpenEdge 10.1A

    Java 1.4.2

    Tomcat 4.1.30

    WSA seems to be good.

    I make wsm and wsd files with ProxyGen on a windows xp client (also OE 10.1A) and I can not deploy the webservice neither with Progress Explorer nor with wsaman on the Linux box.

    Messages:

    Progress Explorer:

    Failed to deploy Web Service for: wsa1

    AdminServer unable to recognize WSM content.

    On Linux:

    Unable to read WSM file: ./TestService.wsm (10803)

    - the file should be available, of course, so the reason is something else.

    I found few entries on the EPG and in the KB, went through but still stucked. Any ideas ... ?

    TIA,

    -istvan

  • I'm not sure if this is necessary, but these are the steps that I always went through to deploy a web service on linux.

    Use windows to describe the service and generate it. I threw away the .wsm and .wsdl files and instead took the .xpxg file which is more or less the file that describes all the settings you used to describe the service (propath, input output params, everything you set in the proxygen tool).

    I transferred this to the linux machine and edit'ed it to make sure that all the relative paths came out correct and then ran bproxygen on the linux host. The resulting .wsm files didn't have any troubles being deployed.

    I was working under 10.0b, and don't know if all of the above was truly necessary, but it was the way that I got it working. Note that the r-code can change as much and as often as you want so long as the inputs and outputs don't change, you don't have to regenerate the service.

    Now the deployment part was a little tricky also with the order of operations. If this doesn't solve your issue, ask again and I'll look up the old instructions.

    Hope that helps,

    Darrell Davis

    Allegro Consultants

  • Dear Darrell,

    I have also faced the similar problem while deploying the wsm file in the Web Service Adapter. It throws the error: "WSA Request Error: REQUEST FAILURE". What kind of error is this? Due to this error, I am not able to deploy the web service.

    What I actually did is,

    I created a .p file with a query that returns all the records from a table of sports2000 database with a procedure name p-first like this.

    PROCEDURE p-first.

    FOR EACH customer.

    DISP customer.custn.

    END.

    END PROCEDURE.

    It is saved as test1.p.

    Afterwards, I compiled it and test1.r is produced.

    Then, in the Proxy Generator, i created a new AppObject named it as FirstAppObj and added in the Persistent Procedure, the .r file that is produced.

    I clicked on Generate button and I clicked only for Web Services toggle box. In the fourth tab of Web Services, I configured as:

    urn:NS1

    URL for WSA: http://localhost:8080/wsa/wsa1 (it is working with Apache/Tomcat)

    SOAP Action: blank

    Session-Model: Free

    WSDL Settings : All Default

    The Proxy Generation succeeded with the succeeded message.

    Now, I wanted to deploy the FirstAppObj.wsm to the Web Services Adapter. In the Web Services Adapter right pane, I started with Deploy a New Web Service.. option.

    It prompted for wsm path and filename where I feed the above wsm file. Then it again prompted with Deploy: Deployment Information dialog box, where the information is

    Name: FirstAppObj

    Web Service NameSpace: urn:NS1

    SOAP Action: Blank

    No check for Append to SOAP Action toggle box

    and Default radio option checked.

    After pressing OK, it generates error message.

    Failed to deploy web service for : wsa1.

    WSA Request Error : REQUEST FAILURE.

    I couldnot proceed ahead than this.

    So, I want to know from you guys whether I have to change on any my files, may be .wsm file or somewhere on .xpxg file.

    Please help me to sort this out.

    Thanking you in advance.

    With regards,

    Kamal Raj Subedi

    Javra Software Nepal

    IT Park, Banepa

  • Hi All!

    I found the solution for this problem. The URL in the properties of the Web Services Adapter was wrong, so I changed it to the location of wsa1 adapter (in my case, it was http://localhost:8080/wsa/wsa1 for test in localhost). This wiped out this problem.

    But again after another problem came, "Web Server Authentication Failed". This is the case of Authentication failure i.e. wrong username/password. For test, I just made this not to check the authentication by changing in two files.

    i) Web.xml in the wsa folder where the Web Service is. i.e. within the webapps folder of the TomCat Apache folder in Program Files. There all the Security-Constraint tag is commented out like this.

    ii) Second in the ubroker.properties file of the appserver broker log.

    There in the place where there is AdminAuth = 1, I changed it to be AdminAuth = 0.

    After doing these stuffs, I could deploy the .xsm file as a web service.

    But again, I don't know how to use this web service in another program. If anybody know how to use, then please help me to find out.

    Note: This all are the case of Windows XP. In Linux/Unix, I don't know how to solve it.

    With regards,

    Kamal Raj Subedi

    Javra Software Nepal Pvt. Ltd.

    IT Park, Banepa

  • Hello ,

    1.when you are creating a new web service adapter you should take care that

    URL mention in this should be same as when you install progress . If it is differ

    then it will create such type of problems.

    2. before craeting this Tomat should be start.

    Actually i already face such type of problem and follow this steps then I was able to solve this problem.

    if you will follow this instructions then i feel your problem will be solved.

  • Hello Rohit,

    I am in confusion whether the web service adapter URL mention should be same or not with what we provided when we install progress. Which URL of progress are you trying to mention, I don't clearly get. Please let us know.

    I have also wrote a 4GL client program and tried to connect to the AppServer through WSDL file which is success. Here, I didnot mention URL of progress at the URL of web services adapter, which exactly I don't know even. Instead, I have provided the URL of localhost port where the TomCat/Apache is installed. The full path is like this, http://localhost:8080/wsa/wsa1. Of course, I have started TomCat before using this, which is a must.

    Apart from connection, I could not call the procedure of the deployed .p file. A SOAP error comes when tried to call that function. The error is like this:

    Web Service Operation CreatePO_Test1 generated a SOAP fault. SOAP faultstring is: An error was detected in the Web Service Request. (10894)(11506).

    Please help me.

    With kind regards,

    Kamal Raj Subedi

    Javra Software

  • Hello all,

    Here are some tips. I had to go through a number of step to get this webservices stuff running. I will try to be brief....

    I am using:

    OE 10.1B

    Linux

    Tomcat 5.0.28 (Linux)

    Step 1: Tomcat install

    Install / copy a instance of Tomcat to the desired location.

    Step 2: Configure Tomcat

    Edit tomcat\conf\server.xml

    add: (Not really necessary)

    run-time properties

    set webAppEnabled = true

    Step 8. Deploy

    Deploy the WSM in the explorer tool and enable it.

    Step 9:

    Check the url http://localhost:8080/wsa/wsa1/wsdl

    If all went ok, the newly deployed webservice is in this list.

    NOTE:

    I think I read something somewhere (??) about problems when Tomcat and the appserver etc are installed on different servers. Never tried it, just putted them on the same server. Sorry, don't know what problems it were exactly. Think something about connecting to the servlet with the explorer tool.

    NOTE 2:

    Because the same user is added in tomcat you can set the wsa1 property "WSA Administration user Authentication" (security) on " Use AdminServer user authentication"

    Hope this will be of any help...

    Oh yeah forgot: You will need a State-Free appserver as well !!

    Message was edited by:

    Peter Palm