Unable to launch Domain Manager - Forum - Technology Partner - Progress Community

Unable to launch Domain Manager


Unable to launch Domain Manager

  • Hi ,

    We have installed Sonic recently in our machines.But we are unable to launch domain manager and getting error messages like configuration cache is locked. I am attaching error message here below. Please help me to resolve

    this. Thanks in advance.


  • Are all the containers shutdown? If it is a workbench installation upon starting the Workbench it would start the domain manager internally. Did you try stopping the domain manager using the program shortcut "Stop Domainmanager", if that doesn't help look in the task manager for any java processes. Identify and kill the appropriate java process.  If there are no java processes running go to the c:\sonicwb\MQ7.6\Domain1.DomainManager.cache" folder and delete the cache.lock file.

  • Since it is the first time installation we haven't configured any new container. Stopping DM(domain manager) doesn't help, as restarting DM after shutdown gives us the same error.

    We are not sure if Domain1.DomainManager.cache is being used by any JAVA process; So attaching all the JAVA Processes of Sonic workbench. Let me know if any of them is using  Domain1.DomainManager.cache.

    Cache.lock file will be in use after launching workbench and  get deleted automatically upon exit. We can not delete it when Sonic workbench is running.

  • Since you have started the Workbench it started the Domain Manager internally. In that case you need not start the domain manager again. If you want to start the DomainManager outside the Workbench. First shutdown the Workbench wait untill the Domain manager is shutdown properly. Then you start the Domain Manager using the program group shortcut. After the DomainManager is started you can start the Workbench.

  • We have done this already, but getting the same error.

  • Do the following

    1. shutdown the workbench
    2. wait for sometime and in the task manager if there are any java  processess appearing kill them (assuming you are not running any other  java application)
    3. verify that the lock file is gone
    4. start domain manager
    5. if it starts then start the workbench
  • Hi,

    I have tried the above steps, still getting the same error.'Domain Manager start up failed.

    Reason:Configuration Cache is  locked.The cache directory c:\sonicWB\MQ7.6\Domain1.DomainManager.cache is used being used by another container,which must be shutdown before starting this container'.

  • After shutting down everthing and all the java processes are killed try deleting the cache folder and lock file.

    Can you please attach the domainmanager contianer log file after you have shut down the workbench and the domain manager.

    Sometimes the task manager might not identify all the running java processes, you can try installing the process explorer (http://technet.microsoft.com/en-us/sysinternals/bb896653.aspx) and see if you are able to view any java processes and kill the tree.

  • Hi,

    Please make an entry in the hosts file under driver/etc folder with the ip address of localhost and hostname. Hostname will be the name which it is trying to ping while starting the Domain manager.



    Let us know if it is working.


    Sudarshan Kumar