Error while migrating 3.7 to 4.2 - Upgrading Sitefinity - Upgrading Sitefinity - Progress Community
 Upgrading Sitefinity

Error while migrating 3.7 to 4.2

  • Error while migrating 3.7 to 4.2
  • HI,

    I am migrating project sf 3.7 to sf 4.2.

    1. I have followed each and every step described in migration guide.
    2. Before that I migrate the project into sf 3.7 SP4 (.NET 4.0) from sf 3.7 (.NET 3.5) and working fine.
    3. Here I checked MigrationService.svc service in sf 3.7. 
    4. SF 4.2 Part,
    5. In Sitefinity/Administration/Migration, I copied URL of sf 3.7 project and successfully got message “Connection established.”
    6. Then started to migrate one by one all given option, at last migration was successful except libraries & blogs.

    a)    Error in libraries, “Telerik.OpenAccess.RT.sql.SQLException: Cannot insert the value NULL into column 'Application', table 'Test.dbo.sf_Libraries'; column does not allow nulls. INSERT fails. The statement has been terminated.”

    b)    Error in blogs. “The remote server returned an error: (400) Bad Request.

    1. I copy physical files (App_Data, master pages, images, documents, User Controls, templates and other referenced file) as described in migration guide.
    2. In admin part, I can see lists of all pages and relevant content but not able to browse or view. 
    3. And when I browse the website, it was giving me exception for dll and one by one I placed it from sf 3.7 whatever required.

    After all,

    1. Sometimes it’s displayed “Could not load file or assembly 'Telerik.Web.UI, Version=2010.2.826.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0X80131040)” even it is same (new version dll and not updated with old) as displayed in error.
    2. Sometimes In home page vertical & horizontal menu (its Rad Menu Control) are not appears (instead of menu  - displaying above mentioned error).

    Please help me to resolve query.

    Your feedback will be highly appreciated.

    Thanking you,

  • when you say "migrate one by one" do you mean that you ran the migration tool multiple times for each content type?

    Have you tried running them all in one batch? I haven't tried running the tool more than once...

    regarding the assembly error, check your master pages and controls, make sure that any @Register tags don't contain the assembly versions, sometimes they get hard coded onto the page.

    I hope this is helpful, can you also provide your migration log?
  • Thanks for your support

    yes, first I tried to migrate all with one click. but it's fail on libraries and need to start again from libraries and for further content.

    I checked in master pages and user control. Here I found register tag only in user control that is,
    <%@ Register TagPrefix="telerik" Namespace="Telerik.Web.UI" Assembly="Telerik.Web.UI" %>

    Another thing i found that <telerik> is not allowed in web.config file for version 4.2

    And here I am not able to attach log file

  • Hi Joshua,

    Thank you for providing additional information.
    Concerning the problem with not properly referenced assemblies.
    1. Sitefinity is trying to load an old Telerik.Web.UI assembly Version=2010.2.826.40 which is old version and Sitefinity 4.2 uses the latest version of this assembly 2011.2.712.40. I suppose a user control is requiring it or the required version is hardcoded somewhere as required. Can you make a search for this version in your solution to see if you will find it somewhere. If you add the new assembly double check if it is in the bin folder of your project and the same assembly is referenced in the Visual Studio project.
    Another thing that might be causing a problem is if you don`t have the latest version of the RadControls installed, they are available with Sitefinity 4.2 SDK
    2. The menu is a RadControl and uses Telerik.Web.UI assembly. Can you make sure you have referenced the correct assembly.

    Best wishes,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hello,

    we have installed Telerik 4.2 and it's working great but we have an issue that didn't happen in version 3.5.
        We have created our own Master Page in visual studio 2010 and trying to integrate it into telerik using the Template section in the CMS by specifying where we copied our Master Page file.

    -> Masterpage copied at the root folder of the SiteFinity
    -> Once on SiteFinity CMS : Design -> Page Templates -> ... -> use our own master file

    The problem : Css files and images are not loaded into my MasterPage.

    Would you have any clue regarding this issue ?

    Many Thanks.

    Lucas Loeffler
  • Hi Johnny,

    The paths pointing to images and css documents might not get resolved.  What are the paths are you using to locate the files?
    Can you check referencing them like this.

    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • 364101_Migration-issue.png
    We have website in SF 3.7, and wanted to migrate to SF 5.0.
    For that,I have installed SF 5.0, and started migrating using the steps given in link.
    I have successfully migrtaed up to Templates. But it gives "The remote server gave internal server error 500", and pages are not migrated.
    Please help me with this issue...

  • Suma, can you check the error logs of the 3.7 site as well as the Event Viewer for that machine for any exceptions that can tell you more about what might have gone wrong?

    If so please report them in a new thread (or support ticket) so we can better attend to your issue, thanks!