Can't administer site - various errors - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

Can't administer site - various errors

  • Can't administer site - various errors
  • Fresh install of Sitefinity 4.0 on Windows 7 computer.  AOK.
    Sitefinity Project Manager 4.0.1098.0

    Today, since I have received no reply via the standard support process, I thought I'd try the forums.
    I go back into the Sitefinity Project Manager and click "Create New Project"
    I get a popup error window
    "Unhandled exception"
    X => NotSupportedException
            This stream does not support seek operations.

    Previously (a couple days ago), I created a site, but the creation is incomplete since it now shows Status=Offline in the Sitefinity Project Manager.  Here is my experience trying to create the site originally:  (I have posted this problem in the Support section, but still no reply today)

    Create new Project Wizard - create
    Location = FTP (because I couldn't get HTTP to even deploy the files due to "FrontPageRPCException: Could not retrieve the server extension version.")
    Click "Browse"
    [Choose location wizard appears]
    server = <our server name>
    Port: 21
    Directory / <enter "/" because ftp user is directed by the ftp server to the correct web virtual directory folder>
    Unclick Anonymous
    User name: <our ftp user name>
    Password: <our ftp password>
    Click OK
    [Choose location wizard closes]
    Project Name: <our project name>
    Click Next
    [Activate a license]
    Choose "Use a license...", point it to the file via "Browse"
    Click Next
    [Confirm license appears]
    Click Finish
    The process remains silent for a few seconds, then I see the project in the list.  It shows the URL and Location.  The location is correct, but I don't understand why it's putting the ftp login credentials in front of the URL string (ftpuser:ftppassword....)
    Clicking "Browse" causes nothing to happen.
    Clicking "Go to Administration" causes nothing to happen.
    Right-clicking --> Show License Info displays:
    X=>NotSupportedException This stream does not support seek operations.

    When I browsed to the page via IE8, I got a file-system security error, so I checked the user context and it was IIS_WPG, so I added that user to the file system folder with full right.  I can now browse the site, and I get the "Thank you for visiting our web site.  Please return soon for updates." page.  So IIS is basically working. 

    Curious, since I had modified the directory security, I once again tried to create the project via HTTP  (e.g., Remote) instead of FTP.  In this case, I got the same FrontPageRPCException error.  I knew IIS7 had a problem with FrontPageExtensions not existing, but we're not dealing with IIS7, this is IIS6 on Win2003 server.  This was explained in
    and I have noted that the web.config that is in the generated site on the web server does indeed have the "remove verb" setting as indicated in the KB article.

    Unable to administer any sites.
  • Hi Larry,

    I saw you had another support request opened, so let's keep the discussion there. Thank you. 

    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items