Upgrade of Sitefinity 4.1 to 4.1 SP1 on Azure - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

Upgrade of Sitefinity 4.1 to 4.1 SP1 on Azure

  • Upgrade of Sitefinity 4.1 to 4.1 SP1 on Azure
  • I would like to upgrade my Sitefinity 4.1 to 4.1 SP1 on my Azure installation.  The upgrade instructions say to do the upgrade on your local machine after copying the database locally.  Is it possible to instead install the new release in the Azure instance?  Specifically, copy all files but ~/App_Data/Sitefinity/Configuration?

    If you can't do it that way, can you recommend a best practice for copying the Azure SQL database locally?

  • Hi Brian,

    Thank you for using our services.

    You can perform this operation. You have to upload all files except the configurations folder. Also, please make sure that if you have custom modules you recompile them for the new assemblies.

    Radoslav Georgiev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • This worked just fine.  I did the upgrade on my development machine without copying the database down from Azure.  I then manually deleted System.Windows.dll from the bin directory (even though copy local was false).  This avoids the 'Unable to load one or more of the requested types. Retrieve the LoaderExceptions property for more information'' exception.

    Then I zipped up the App_Data/RadSpell, bin, ClinetBin, NewsletterTemplates, and Sitefinity folders.  Also the following files in root: CountryCenterLocations.config, Default.aspx, Silverlight.js, wlwmanifest.xml, web.config.  I of course manually merged the new web.config with the old one.

    Then, I uploaded this zip file to my Azure instance, and unzipped its contents to a temporary folder.  Then I copied all the files in the zip to E:\sitesroot\0 on the instance.  Finally, I copied the new Sitefinity.lic to E:\sitesroot\0\App_Data\Sitefinity.  Then you just run the home page and wait.  Admin worked fine too.