Azure and Sitfinity 6.x Deployment - Share your experience? - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

Azure and Sitfinity 6.x Deployment - Share your experience?

  • Azure and Sitfinity 6.x Deployment - Share your experience?
  • Hello,

    I am looking into deploying several SE Sitefinity to Azure.  I noticed the Sitefinity documentation is somewhat dated since Azure has upgraded and SF keeps referring to v4.x   but in different forum posts SF said that certain issues would be resolved in v6.x as it relates to Azure.

    So is anybody hosting 6.x on Azure and how are your sites performing? Are you using a VM or application? Anything tricky to watch out for?

    SF, please provide input too.

    Thanks!


  • Hello,

    I am not sure which part of sitefinity azure support or documentation still refer to sitefinity 4.x version and please let me know so I can update this.

    For a deployment I can recommend performing the Azure deployment with sitefinity thunder which is automated deployment following a wizard which performs all configuration changes needed for the site to be Azure application automatically, here is the related documentation for Azure deployment.

    The usage of cloud service or VM to host an Azure site is your preference depending on the project needs and estimated user visits in the site.

    Regards,
    Stanislav Velikov
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I switched from using shared host to Azure virtual machine yesterday and it costed me couple of hours to deploy my 6.1 SF site onto Azure virtual machine, most of the time was for uploading files.

    I looked for a virtual machine since I'd love to control everything. I've just followed basic steps and guidelines and so far it's working perfectly.