Error, deploying project to azure web app - On Premise – Configurations & Setup - On Premise – Configurations & Setup - Progress Community
 On Premise – Configurations & Setup

Error, deploying project to azure web app

  • Error, deploying project to azure web app
  • I have followed the instructions from the link below to deploy my project to azure.

    docs.sitefinity.com/publish-your-project-to-azure-web-apps

    But am getting the following error:

    Could not load file or assembly 'Microsoft.WindowsAzure.ServiceRuntime, Version=2.6.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    I have the correct SDK installed. (2.6.0), I have also managed to successfully deploy the same project to an azure virtual machine as a first test.

    Is there something else I need to do?

  • Almost a month and no reaction from the Sityefinity team.

    That is very disappointing considering how much Sitefinity costs.

  • Hello Andrew,

    In case the provided solutions above do not helped, I would recommend you to open a support ticket where to inspect your project more detailed.

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  • d7d8531e-37c1-6deb-a958-ff0000446526_capture.png

    What solution are you referring to?

    I don't see anything here.

  • Hi Andrew,

    it is strange. I am posting it again:

    We were unable to reproduce the exception on our end. Can you try to upload your website using the powershell scripts located at our GitHub repository.  You can find more information about it on our documentation page: docs.sitefinity.com/deploy-projects-using-powershell-scripts

    If you still experience the same issue, can you try to add a binding redirect in your web.config for the WindowsAzure.Service.Runtime assembly like this:
    <dependentAssembly>
       <assemblyIdentity name="Microsoft.WindowsAzure.ServiceRuntime" culture="neutral"publicKeyToken="31bf3856ad364e35" />
       <bindingRedirect oldVersion="0.0.0.0-2.6.0.0" newVersion="2.6.0.0" />
    </dependentAssembly>

    Regards,
    Svetoslav Manchev
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  • I ran into this.

    I FTP'd into Azure and noticed that the Microsoft.WindowsAzure.ServiceRuntime was missing from my BIN folder so I FTp'd that in.

    Next I got an error about Microsoft.WindowsAzure.ServiceRuntime.RoleEnvironment throwing an exception.

    I then found this: www.sitefinity.com/.../error-when-deploy-on-azure-using-github-powershell-scripts

    I noticed that the msshrtmi.dll was also missing from the BIN folder so I FTP'd that in out of the Azure SDK directory.