Failed workflow operation - General Discussions - General Discussions - Progress Community
 General Discussions

Failed workflow operation

  • Failed workflow operation
  • Hi

    When I try to Publish or Save as Draft i get a Popup saying Failed workflow operation and the page changes doesn't get saved.

    I'm having EN & Swedish as languages. I've checked no Workflow active.

    /Keivan
  • ... got the same issue.
    Did you find a workaround ??
  • No, so this is my biggest problem, can't do anyting on the site.

    /Keivan
  • I've worked all day long yesterday to try to find a workaround the "Invalid time zone standard name", and finnally I installed a brand new Windows Server 2008 R2 in english with SQLServer 2008 R2 and Sitefinity...
    After long hours I got it to work... but immediately found that "Failed Workflow operation" whenever I try to save a page. Everything else seems to work but if it is impossible to save a page, them I'm definitly stuck...

    I have to admit that these two poblem combined are making Sitenity 4.0 RC completely unusable for me...
    This is frustrating.

    By the Way, my Windows server is purely US english with no french at all...

    **EDIT**
    In fact, this Failed Workflow thing does NOT happen if Sitefinity is used from Visual Studio 2010. It happens ONLY if project is used under IIS 7
  • I'm having the same problem. I've installed the RC version on Windows2008 server and SQL2008. I can not create a new page. It always says:Failed workflow operation
  • Possible Solution
    When I was first installing SF on the server I noticed that I was prompted to install the latest Telerik control suite to which I declined. For some reason I thought I had clicked on the wrong installer. I reinstalled the SDK this time installing the latest version of Telerik controls this time. Now, I seem to be able to use SF 4 as I imagined it would be. I don't get the WorkFlow errors anymore. 

    Sitefinity.4-0-907-0.msi reinstallation seemed to get me back on track. 

    EDITED
    Nope, I am still receiving the Failed Workflow Operation Errors. 

    Please Fix this problem!

  • PROBLEM SOLVED
    I noticed that the SF4 worked fine until I integrated my projects. So, it appears that the legacy references, from work that I had done in the past, to Telerik assemblies are the root of the problem. After removing the dlls from my legacy projects, my publishing worked fine.

    Found the problem References

    So, the logical thing to do was to go and check what was going on in those projects. I looked inside the dll and sure enough there were references to Telerik.OpenAccess from the past.

    Removed the References from the Problem Project
    Beware, I had a rough time removing these references. I went to my project settings and removed all telerik references from the project. I also deleted the files in the bin and recompiled. 

    Side Note
    I remember in this particular project I was having trouble working with OpenAccess so I dumped it for LINQ to SQL. Therefore, those problem references (to Telerik.OpenAccess) weren't necessary. Most likely you will have to update the Telerik References in your project for this problem to go away. In my case, I just irradicated them.

    Finally Removed The References
    I had surely removed every trace of Telerik from the problem project. Still, I got the Failed Workflow Operation again. So, I opened up the dll from the project with Red Gate Reflector. That revealed that there was still a reference to Telerik.OpenAccess. Because, I couldn't seem to kick this problem,  I created a new project and moved all the files into the new project, compiled and then...

    SUCCESS!
    I am now in business--fingers crossed--but it looks good so far.
  • Brilliant!
    I hope that this will be usefull to the Telerik guy to understand and fix the problem for this week's build!
  • Not so Fast..
    I did this on my development machine and was getting the Failed Workflow Operation. The aforementioned steps did get me working on this machine. I haven't however been able to get it working on my server. So, I don't think we are out of the woods yet. 

  • I'm pushing this topic "up".
    Please you guys from telerik, would that be possible to include a fix for this issue in your release today, or as "soon as possible" ?

    We know that your are doing your best, thanks for that.
  • Any response from Telerik?
  • I have the same problem!
    Uninstalled everything. No luck.
  • The new build is online.
    Problem disapeared.

    Solved.

    Thanks guys.
  • Still happens for me :(