500 - Internal server error (Shared Hosting w/ Full Trust) - General Discussions - General Discussions - Progress Community
 General Discussions

500 - Internal server error (Shared Hosting w/ Full Trust)

  • 500 - Internal server error (Shared Hosting w/ Full Trust)
  • We are trying to push out Sitefinity to a shared hosting environment with full trust permissions. Everything works, except the backend. It seems that anything requiring a "write permission" fails - for example, when I go to Administration > Settings, update the time zone, and click save, I get a popup message that says "500 - Internal server error".  Same thing goes for when I try to update pages, add news items, etc.

    The strange thing, is now all of a sudden I am unable to navigate pages, news items, images, etc. I get an error message stating: "Could not deserialize service response, because it was empty or not a valid JSON."

    Any ideas as to what could be happening?

    Few things to note:
    - On a shared server so very difficult to troubleshoot
    - Full trust enabled
    - .NET 4.0
    - Tried both x86 and x64
    - Full write permissions to App_Data + children (also tried full write to entire directory)
    - Full write to database
    - More than enough diskspace on the filesystem and db
  • Also, the error logs in App_Data/Sitefinity don't show anything other than "Logging Started".
  • Hi Ed,

    Can you try to create a content item and then category or taxon. Then check the svc log tracer.
    There should be some more information about the actual error.

    Greetings,
    Ivan Dimitrov
    the Telerik team
  • It's been a long while, but I finally had time to revisit this. I tried installing v4.2 on a shared hosting environment, .NET 4.0, with full trust (at MaximumASP/Cbeyond, Cloud Sites platform). Still having the same issues - the frontend seems to work okay, but the backend breaks whenever it needs to write to the database of config file.

    I ran the log trace as suggested. The error (all the same when creating a page, news item, or creating a category) states:

    Activity: Open ServiceHost 'Telerik.Sitefinity.Modules.Pages.Web.Services.PagesService
    Error: Configuration evaluation context not found.

    I was able to get a WCF service to work at this hosting provider in the past. They are also not sure why Sitefinity would be causing such an error and suggested that I try asking Telerik for suggestions. Keep in mind a few things - the hosting provider's shared environment consists of load balanced servers. As instructed by the provider, I setup a machine key in the webconfig and setup SQL-based session state. I've also verified that the App_Data folder is writable by the app pool.

    Below is the error in more detail, although - doesn't state all that much outside of the error. If you would like to see the complete log trace, please let me know where to send that to.

    Thanks,
    Ed Sirijintakarn

    <E2ETraceEvent xmlns="http://schemas.microsoft.com/2004/06/E2ETraceEvent">
    <System xmlns="http://schemas.microsoft.com/2004/06/windows/eventlog/system">
    <EventID>524312</EventID>
    <Type>3</Type>
    <SubType Name="Warning">0</SubType>
    <Level>4</Level>
    <TimeCreated SystemTime="2011-08-23T15:53:03.5594807Z" />
    <Source Name="System.ServiceModel" />
    <Correlation ActivityID="d2101ec8-7b3d-4ff1-99b2-1bd56088312c" />
    <Execution ProcessName="w3wp" ProcessID="6804" ThreadID="9" />
    <Channel />
    <Computer>******************</Computer>
    </System>
    <ApplicationData>
    <TraceData>
    <DataItem>
    <TraceRecord xmlns="http://schemas.microsoft.com/2004/10/E2ETraceEvent/TraceRecord" Severity="Warning">
    <TraceIdentifier>msdn.microsoft.com/.../TraceIdentifier>
    <Description>Configuration evaluation context not found.</Description>
    <AppDomain>***************</AppDomain>
    </TraceRecord>
    </DataItem>
    </TraceData>
    </ApplicationData>
    </E2ETraceEvent>
  • I have exactely the same problem on a VPS.

    Backend login works fine. But when ever I want to do someting save a page, add languages I get the error.

    I sure would hope someone had an idea on this because at the moment I am clueless. Its a fresh 4.2 installation.

    Sorry to say: glad someone else has the same problem.

    Just to make sure I did delete my db and made a fresh install.

    This is what works

    - I can add a comment in my profile
    - If i go to my Administration - Users and change the image of my account the image gets uploaded but the saving fails.

    Strange. Any idea is welcome. IIS, SQLExpress anything.

    Markus
  • Hello Markus,

    Is there info in the service tracer log?

    Regards,
    Ivan Dimitrov
    the Telerik team

    Thank you for being the most amazing .NET community! Your unfailing support is what helps us charge forward! We'd appreciate your vote for Telerik in this year's DevProConnections Awards. We are competing in mind-blowing 20 categories and every vote counts! VOTE for Telerik NOW >>

  • Dear Ivan

    I have a ticket open. As soon as I have the answers, solutions I will post them here.

    Markus
  • Yes, Please post them here. I am having the same exact problem.
  • I had a similar problem being unable to save any changes to pages or settings that turned out to be my UrlScan config, had to change it to allow PUT and DELETE verbs. Are you using that on your VPS/Hosting?
  • Dear Ryan

    Yes VPS. Any instruction on how to do it or where to look for it?

    Markus
  • If it is installed the config file should be at

    %WINDIR%\system32\inetsrv\urlscan\UrlScan.ini

    Look for the [AllowVerbs] and [DenyVerbs] sections.

    Ryan
  • Nice to see that I'm not alone on this one.

    Don't think UrlScan is enabled where I am at though - and if it were, wouldn't have access to that config file either since it's on a shared environment.

    Thanks,
    Ed Sirijintakarn
  • Hi Markus,

    Were you able to resolve the issue pertaining to the error "Could not deserialize service response, because it was empty or not a valid JSON?"

    We're experiencing the same error when trying to edit or create a page in our staging environment. The entire publish/save as draft/preview toolbar is also missing, and Firebug shows that the edit page throws a Javascript error, "<function name>  is not a function". The odd thing is, this is only happening on staging, not on local machines (with the exact same code base and database, of course).

    We're also thinking it's possibly due to an IIS 7 setting?

    Thanks,

    Wendy
  • Dear Wendy

    I ended up deleting the site and db. Creating the project again on the server. Have you checked if you have some tables double in your staging db like dbo. and yourprojectname.

    Markus