Problem installing meetings custom module - General Discussions - General Discussions - Progress Community
 General Discussions

Problem installing meetings custom module

  • Problem installing meetings custom module
  • 262563_FireShot-capture-027---Settings---localhost-53307-Sitefinity-Administration-Settings-Advanced.png
    Hi,
    I created a new SiteFinity 4.0 project and I'm trying to add the Meeting module from the Intranet Starter Kit. Here's what I did:

    1. Added reference to Telerik.Sitefinity.StarterKit.Intranet.Meetings.dll
    2. Registered the module (see attachment)
    3. Registered the widget

    The widget appears in the toolbox under the Custom section but I dont see the Meeting link under the Content top menu.

    Am I missing something? Any sort of help would be greatly appreciated.

    Thanks
  • Hi Raihan,

    Seems you have not registered the module properly. Please check the following tutorial in order to correctly reference all dependencies and achieve the desired result.

    Best wishes,
    Victor Velev
    the Telerik team

  • Hi,

    Thanks for helping out. If you check my screenshot, I havent missed out any step mentioned in the tutorial. Please corrent me if I'm mistaken. Furthermore, the values of the fields are different from the tutorial because this is a different module.

    Thanks
  • Hello Raihan,

    Can you give me more details about your module - if possible upload the source so I can take a look at it and be of greater help.

    Kind regards,
    Victor Velev
    the Telerik team

  • Hi Victor,

    As I mentioned earlier, I got the module from the starter kit and I did not make any changes to the code. You can download the module from here:
    www.sitefinity.com/.../intranet.aspx

    The module is Telerik.Sitefinity.StarterKit.Intranet.Meetings.dll
  • Hello Raihan,

    Can you please verify that the module .dll is in Sitefinity folder. Also please change the startup type to:

    startupType="OnApplicationStart"

    and restart your project.

    Greetings,
    Victor Velev
    the Telerik team

  • The module .dll is present in the reference folder? Should I add it somewhere else? How do I restart my project?
  • Hi Raihan,

    The .dll should be present in Sitefinity's bin folder. You can restart your project simply by adding a random character, deleting ( in your webconfig ) and saving it thus restarting the website ( without making unnecessary changes ).

    Regards,
    Victor Velev
    the Telerik team

  • The .dll is present in the bin folder and I restarted the website by modifying the web.config but I dont see the Meetings module in the Content menu but I see my other custom module. The following two entries are present in the SystemConfig.config under App_Data/SiteFinity/Configuration

    <applicationModules>
    ..
    <add title="Meetings" description="" resourceClassId="" type="Telerik.Sitefinity.StarterKit.Intranet.Meetings.MeetingsModule" startupType="OnApplicationStart" version="1.0.0.0" name="Meetings" />       
    <
    add title="Jobs" description="" resourceClassId="" type="Jobs.Jobs_Module" startupType="OnApplicationStart" version="1.0.0.0" name="Jobs" />

    </applicationModules>


    When I click on 'Content' in the top menu, I now see "Jobs" but I dont see "Meetings".

    Thanks
  • Hi Raihan

    Try to delete the version from the module and restart the applicaiton. This is how your systemconfig.config should look like:
    <applicationModules>
    <add title="Meetings" description="" resourceClassId="" type="Telerik.Sitefinity.StarterKit.Intranet.Meetings.MeetingsModule" startupType="OnApplicationStart" name="Meetings" />       
     
    </applicationModules>

    When there is no version the Sitefinity 4 tryes to install the module.
  • Hello Raihan ,

    Can you give us up - to - date information about your current issue?

    Kind regards,
    Victor Velev
    the Telerik team

  • I have the exact same problem and I am still facing it with all the suggestions fulfilled.
    I even tried with different browsers - no help.
    Any new suggestion?
  • Hello Ani,

    After you have added the module as reference to SitefinityWebApp, added the proper entries to the settings files and restarted the project the module still has not showed up? Can you please provide screenshots of the following:

    1. The registered module in the backend settings.
    2. The module structure and files.


    Regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi Victor,

    See my files attached and tell me if I missed something.