Special characters in pages titles in Q1 - General Discussions - General Discussions - Progress Community
 General Discussions

Special characters in pages titles in Q1

  • Special characters in pages titles in Q1
  • Hi,
    It seems that there is an issue in the page title for Sitefinity 4.1, I can't write a comma or a pipe character in the title field of the page.
    I got "Special characters" error.
    have a look on the attached images.

    Thanks.

  • You are right: one more bug in the very long list of 4.1 errors. I got the same bug and I ask myself what Sitefinity really tested before they rolled out this mysterious Version 4.1? Regards Robert
  • 266175_seotitle.png
    Hello,

    This is not a bug. You can remove the validation from the field and enter special chars. You can do this from the UI >> Administration >> Settings >> Advanced >>ContentView >> Controls >> Pages >> Backend Pages.


    Kind regards,
    Ivan Dimitrov
    the Telerik team

  • Thanks Ivan, it works well.


  • Hey there,

    I removed the RegularExpressionFilter and I'm still getting the same error about Special Characters.

    Is there any other area where this could be modified?
  • Hello,

    I am not able to replicate issues with this. Please restart the application after the configuration changes. It is possible that the news settings are not applied.

    All the best,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I just tried to adjust the filter expression following this thread. I was also not able to get the adjustment to work if I set the expression in the main SeoTitle config element. In order for the changes to work, I needed to adjust the regular expression under the Validation element under the SeoTitle. Then I restarted my application and the adjustments worked.

    Edit:
    I was using the latest 4.1 SP1, 4.1.1395, when trying to make this adjustment.
  • I was able to get this to work in 4.1 SP1 but modified the create and edit views and modified both the validation section and the basic title section as mentioned.  Here are the changes I made:

    ContentView -> Controls -> FrontEndPages -> FrontEndPagesCreate -> Sections -> SeoSection -> Fields -> SeoTitle

    On this page I changed hte regular expression filter.

    ContentView -> Controls -> FrontEndPages -> FrontEndPagesCreate -> Sections -> SeoSection -> Fields -> SeoTitle -> Validation

    On this page I changed hte regular expression.

    I then did the same edits to the FrontendPagesEdit section (next view in teh front end pages below create in the same areas.

    I hit save and the changes worked without issue.

  • Gosh none of these is working. If I knew 4.1 was this buggy I wouldn't have pushed for deployment of our websites using it.
  • I followed the steps above and got everything working. Not sure for older versions but this works fine in SP2 and after my upgrade to SP3.
  • I'm using 4.3 and this doesn't work for me by editing in 2 places

    I have changed both
    ContentView -> Controls -> FrontEndPages -> FrontEndPagesCreate -> Sections -> SeoSection -> Fields -> SeoTitle -> removed the RegularExpressionFilter

    and
    ContentView -> Controls -> FrontEndPages -> FrontEndPagesEdit -> Sections -> SeoSection -> Fields -> SeoTitle -> removed the RegularExpressionFilter

    after editing ContentView -> Controls -> FrontEndPages -> FrontEndPagesEdit -> Sections -> SeoSection -> Fields -> Validation -> removed the Regular Expression
    and
    after editing ContentView -> Controls -> FrontEndPages -> FrontEndPagesCreate -> Sections -> SeoSection -> Fields -> Validation -> removed the Regular Expression

    now it works just perfect.
  • I'm using 4.3 and this doesn't work for me by editing in 2 places

    I have changed four locations almost same as above with slight different in path..
    1)  Administration -> Settings -> Advanced -> ContentView -> Controls -> FrontendPages -> Views -> FrontendPagesCreate -> Sections -> SeoSection -> Fields -> SeoTitle -> removed the RegularExpressionFilter

    2)  Administration -> Settings -> Advanced -> ContentView -> Controls -> FrontendPages -> Views -> FrontendPagesCreate -> Sections -> SeoSection -> Fields -> SeoTitle -> Validation -> removed the RegularExpressionFilter

    3) Administration -> Settings -> Advanced -> ContentView -> Controls -> FrontendPages -> Views -> FrontendPagesEdit -> Sections -> SeoSection -> Fields -> SeoTitle -> removed the RegularExpressionFilter

    4) Administration -> Settings -> Advanced -> ContentView -> Controls -> FrontendPages -> Views -> FrontendPagesEdit -> Sections -> SeoSection -> Fields -> SeoTitle -> Validation -> removed the RegularExpressionFilter

     

    now it works just perfect.   
  • Hi Suresh,

    Looking at the last line of your post "now it works just perfect." I believe that the issue has been resolved for you.

    Greetings,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items