Sequence contains no elements - General Discussions - General Discussions - Progress Community
 General Discussions

Sequence contains no elements

  • Sequence contains no elements
  • 268580_Sequence.png
    Now that I fixed our other major issue, I'm back to where I was yesterday.  I submitted a ticket for this, but haven't got a response back yet.

    I am getting a "Sequence contains no elements" error when I try to edit our home page.  Another issue that came out of nowhere..  I've looked at our page template and everything looks fine there, so it must be a control on the page itself.  Any ideas?  

    I've attached the stack trace to this post.
  • Hi Nathan,

    Most probably, some of your ContentBlock controls have no IDs (the ID property is deleted). That breaks Page Editor. This issue will be fixed in the next internal build. As a workaround, you could  try to run the following script

    You can also run the following code to see if there are some issues with the control IDs

    var manager = PageManager.GetManager();
    var controlType = typeof(ContentBlock).FullName;
    var propName = "ID";     
    var controls = manager.GetControls<PageControl>().Where(pc => pc.ObjectType == controlType);
    foreach(var cb incontrols)

        var idProp = cb.Properties.FirstOrDefault(p => p.Name == propName);
        if(idProp == null)
            // the id prop for this control is null

    var draftControls = manager.GetControls<PageDraftControl>().Where(pdc => pdc.ObjectType == controlType);
    foreach(var cb indraftControls)

        var idProp = cb.Properties.FirstOrDefault(p => p.Name == propName);
        if(idProp == null)
          // the id  prop for this controlis null


    Work with database backup.

    Kind regards,
    Ivan Dimitrov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Hi,

    I am new to Sitefinity and am trying to create a demo application for basic understanding using a Sitefinity 9.2 Trial Version.

    After creating a new project in Sitefinity CMS Project Manager, when I am trying to Install Sitefinity Thunder Module in that application using Visual Studio, I get 'Sequence contains no elements' error message, and in the background, the installation process goes on endlessly.

    I could be missing some vital piece of the puzzle. Please help in getting this resolved, as so far I haven't been able to move forward on my demo application work.



  • d8c8551e-37c1-6deb-a958-ff0000446526_thunderinstallationerror.png
    Error screenshot attached.
  • I am having the same issue described by Utkarsh. Would appreciate some guidance on what this might be.

    Thank you,

    Chuck Stark

  • Same problem here, no help from Sitefinity.

    This is not a product ready for the market, at least this Thunder add-on isn't.

  • I think the issue may be that sitefinity Thunder may already be installed. So I logged into the site, and then I went into the menu item titled Administration > Modules and Services and then searched for Thunder module. I inactivated it, and then I uninstalled it.  Then I logged out of the site. Then I went back into my Visual Studio and opened the project up and again tried to install the Thunder module. This time it said it was successful. Then I added a connection using my local url which is something like this. http://localhost:2551 

    obviously your port number will differ.

    It tried to test the connection as I filled out the username and password and continued to tell me it is unsuccessful in establishing a connection. But I went ahead anyway and saved the connection and got a success message.

    I contacted Telerik and let them know their documentation does not take into account thunder already being installed when using Sitefinity Project Manager.

    UPDATE: this time, I created a new instance of sitefinity and I did not inactivate Thunder in the admin > modules and services. Instead, I logged out and then went into my visual studio to create a connection. This is assuming you have already installed the telerik extension into Visual Studio. To create the connection, I first opened a new project/solution which was this instance of the site. I then used the play button in the visual studio menu to build the site and it opens in Firefox. When it does that, it provides you with the url you will need for creating the connection. Then enter your username and password, check the three boxes below if applicable and test the connection. Mine was successful. END OF UPDATE.

    If you find another solution please let us know.