Can't create Search Index - General Discussions - General Discussions - Progress Community
 General Discussions

Can't create Search Index

  • Can't create Search Index
  • Started a brand new project in 4.2 and when I try to create a new Search Index I get the message 'String was not recognized as a valid DateTime'

    This is also happening on an upgraded project.

    Anyone else have this problem with Search Indexes ?
  • I'm not having an issue with the Seach Index but I am with the RSS feeds. I created an RSS feed in 4.1 and then upgraded to 4.2. Went in to make a few changes and couldn't because of the error you mentioned. Deleted the RSS feed and tried to recreate it and get the same error every time now.
  • You can take the coding direct from the some search engine. That will help you a lot.
  • Hello Daryl,

    Getting this error 'String was not recognized as a valid DateTime' is caused by the culture your browser or web server uses. If you use a default culture for the browser ( english US, GB) you will not get this error. This is a bug in SItefinity 4.2 which is already addressed. You can try creating the index with IE9 and it should work.

    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I have tried using IE9 without any success I'm afraid...same issue... really need a workround asap
  • Hello all,

    I need a workaround too. I am using completely standard culture settings in my browser.

    Thanks
    higgsy
  • Hi higgsy

    Workround that works for me based on advice from Telerik is use FireFox and make sure en-US language is installed .. Tools > Options > Languages. and I made this the default....I then had to reboot my machine for that to take effect and then was able to create a search index...

    Although I'm getting confused as to when my pages actually get added to the index... it appears I have to republish them... although that may be something I've mucked up my end...

    Hope that helps.

    Regards

    Daryl
  • Worked for me Daryl, thanks!

    OC
  • Any chance of a genuine solution to this bug? I am using 4.2 and my search index starting throwing this error after an upgrade from 4.1.

    Deleted that index, and now can't recreate. Checked language settings everywhere on advice of this forum - en-GB everywhere I can set it. Tried every browser I can (including FireFox), but no luck.

    Thanks, T
  • Hey Thomas,

    Did you try switching to en-US instead of en-GB? I had to as well (even though I speak Canadian English).
  • Hi KMac,

    Whereabouts, in IE9?
  • Haven't tried ie9 myself but switching the language (Tools-->Internet Options-->Languages) in ie8 fixed it for me. Same with Firefox but I can't remember where the settings are in there.
  • Hi KMac,

    Yeah, had tried it here. With en-US and en-GB.

    Just cleared the whole lot down and re-added the overarching "EN" language (and ensured that the SiteFinity languages matched that too). And now it seems to be working OK.

    Thanks for the advice. SiteFinity 4.2 is fantastic, but it's little things like this (those that need "workarounds") that can make it look a little unpolished sometimes.

    Ta again. T
  • Hey,

    I've successfully done this however my results aren't coming back. Is anyone else experiencing this issue?