Delay When Changing Roles - General Discussions - General Discussions - Progress Community
 General Discussions

Delay When Changing Roles

  • Delay When Changing Roles
  • When I change the roles of a user, I've noticed that there's a delay until they get the new role. They log out and close their browser, but the delay persists. Is there a way to eliminate or reduce this delay?

    Should I have them delete their cookies? Should I have my application delete their cookies upon logout? Doesn't help with people who don't use the logout link.

    Thanks
  • Doesn't seem to be a problem with the cookies, because when calling SecurityManager.Logout(), .SFROLES-Main and .SFAUTH-Main are both deleted.
  • We see the same issue. 
    We update roles of users, using the Sitefinity REST service. The Roles get updated(we verified by getting the roles for user using REST service).

    We have some sitefinity pages restricted to users with roles assigned. Even after a role is removed for a user(and even after logging out, clearing cache, closing brower, accessing in different browser etc.....) , the user is able to see the page listed in navigation. It takes a while for navigation to be updated.

    We get below error in mean time, when we try to access the page:

    Server Error in '/' Application.

    You are not authorized to 'View this page and its child pages' ('Pages').

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.UnauthorizedAccessException: You are not authorized to 'View this page and its child pages' ('Pages'). 

    Please provide a solution.

    Thanks,
    Arun
  • I'm looking into the same problem.

    Is there any news on this anyone?

  • If i remember right.... 

    We removed 'Server Side Caching' and 'Client side caching' completely.

    1. Go to Administration -> Settings -> Advanced -> System -> Output Cache Settings
    2. Uncheck Enable Output Cache and Enable Client Cache
    3. Save the changes
    4. Refresh your site in IIS.

  • Hello,

    The delay can be caused as Arun said from disabled caching and also from running the site in debug mode. Make sure that in web.config that the debug attribute is set to false if the site is in the stage of development where debug is no longer needed.
    <compilation debug="false" targetFramework="4.0" numRecompilesBeforeAppRestart="50">

    Regards,
    Stanislav Velikov
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items