Blog - How to Change ContentEditorFilters - General Discussions - General Discussions - Progress Community
 General Discussions

Blog - How to Change ContentEditorFilters

  • Blog - How to Change ContentEditorFilters
  • We're currently adding a simple HTML5 audio control to our content. By default, the RadEditor strips out certain form tags, which rendered our audio control tags non-functional. This can be overcome by opening the "Advanced" properties and set "ContentEditorFilters" to other settings.

    However we can't seem to be able to change "ContentEditorFilters" for the Blogs. Is there a way to do it?

  • Hello,

    Thank you for contacting us.

    When navigating to Administration -> Settings -> Advanced -> Appearance there are two input fields that control the content filters for the rich text editor. One of the controls it only for the content block widget. To make sure that the correct filters are applied everywhere make sure to specify them in both "RadEditor filters for Content block widget" and "Rad Editor's content filters" fields.

    By setting both of these fields to None I was able to insert "<i>" tags in the blog post's content field correctly (normally i tags are replaced with em tags).

    I hope the above information helps. Please do not hesitate to get back to me if you need further assistance on this matter.

    Regards,
    Velizar Bishurov
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items
     
  • a798551e-37c1-6deb-a958-ff0000446526_capture.png

    Can this be set on an individual Content Block? In the Content Block advanced settings within the page editor, it does show ContentEditorFilters but setting it to None has no affect.

    Am I missing something? We're trying to prevent auto closing of tags on individual Content Blocks.