Publishing Pages Giving Return Code 0 alert message on Sitefinity 5.4 - General Discussions - General Discussions - Progress Community

Publishing Pages Giving Return Code 0 alert message on Sitefinity 5.4

 General Discussions

Publishing Pages Giving Return Code 0 alert message on Sitefinity 5.4

  • Publishing Pages Giving Return Code 0 alert message on Sitefinity 5.4
  • Hi I have created a new project and Tried t publish a page. The page gets created but it is returning with  an alert box "Return Code 0". And I can not add any content to page.

    Please can any one help.

  • a18e1487-4cb5-6f77-96ac-ff0000ae3c70_2013-08-07_1032.png
    Can you confirm under Administration > Settings > Advanced > System > ServicePaths is either blank or your base url like http://localhost

    see attached
  • Thanks for the reply. I confirmed. It is blank. 
    On creating and publishing Templates it works fine.

  • Hi Paul,

    This sounds like a problem I currently have on Sitefinity 6.0. You can get more information if you turn on the Javascript console in Google chome. In my case it shows: "Failed to load resource localhost/.../..." or "PUT localhost/.../MessageWo…" (the actual messages are longer).

    It seems like a permission issue. I can't publish or change any page now so I submitted a support ticket.
  • Hello,

    Based on the information for the issue so far I can `t pinpoint the cause of the problem and the confirmation that page templates publish is successful means the workflow settings for the site work and the workflow is not an issue.

    Please test to create new page wile in the process you keep open firebug or chrome developer tool and examining the Net/Network tab to see if a service fails prior to publishing the page.
    Test creating a page page that doesn`t use a template to see if the template (if custom template is used) is causing interference with the page and resulting in this break.

    Stanislav Velikov
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • It is the same issue for me as well 
    When I inspecton crome the error is
    PUT localhost:8021/.../Mess…itemType=Telerik.Sitefinity.Pages.Model.PageNode&workflowOperation=Publish ScriptResource.axd?d=h6HLhjqHlKB5fFuywTVTbsTv1vjHTcxi_idXbgxN-fTzTGnw40p8Uf…XVLaqCBZ8-LdLUOXgvLCMhBMrXEVE1aGhBuhrVOr_OvJbs8u-UAB0&t=ffffffffe37b2e80:1Sys.Net.XMLHttpExecutor.executeRequest
  • Hi,
    When I inspecton crome the error is
    PUT localhost:8021/.../.........

  • That's the message I get as well in 6.0. I'm waiting for Support to solve this.
  • Hi Paul,

    Stanislav just found that I had a maximum file size on my database. Setting it to allow unlimited growth solved this issue. I can publish pages again. Perhaps this is causing your problems too.
  • Could you share what exactly was done on the database side to correct the issue? We are seeing the same error as described in this thread.