sitefinity:TextField autocomplete=off - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

sitefinity:TextField autocomplete=off

  • sitefinity:TextField autocomplete=off
  • How can I remove the autocomplete to Sitefinity: TextField as autocomplete = "off" does not work

     

     <sitefinity:TextField ID="firstName"   runat="server"    CssClass="sfRequired"
                                DisplayMode="Write" Title='firstNameEnvio'>
                                <ValidatorDefinition required="True"
                                    messagecssclass="sfError" />
                            </sitefinity:TextField>

  • f00ba42b-005b-43ce-8207-0c06a59f4178_TextFieldWithoutAutoComplete.zip

    Hello Omar, 

    You can change the auto complete behavior of the TextField by following these steps:

    • Download the attached file and add its content in your application (for example in the SitefinityWebApp) and build the project
    • Go to the backend of Sitefinity->Administration->Settings->Advanced->Controls->ViewMap and add new entry with the following values:

    HostType:

    Telerik.Sitefinity.Web.UI.Fields.TextField, Telerik.Sitefinity

    LayoutTemplatePath:

    ~/TextFieldWithoutAutoComplete.ascx

    • Click “Save changes” 

    This will replace the default layout file of the TextField with new file with almost the same content, but in the new file we have set autocomplete=”off” to internal  asp:TextBox element.

    If you need any further assistance on this matter please feel free to ask.


    Regards,
    Elena Ganeva
    Telerik
     
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Sitefinity CMS Ideas&Feedback Portal and vote to affect the priority of the items