Products module resources error - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Products module resources error

  • Products module resources error
  • For my project I need a more complex version of the products module, so I just extended it with a couple of fields. I've then Imported the module in my project and all seemed to work well. But when I go to administration -> roles and I then try to edit the permissions on a role, I get the error: Could not find the specified key "Products" or class id "KNLTB.Modules.Products.ProductsResources".

    Normally I suspect that there was a resource key missing, so I just added the following key in my resource file.

     

     

    [

     

     

    ResourceEntry("Products",

    Value ="Producten",
    Description = "The title of CreateProducts security action.",
    LastModified = "2011/05/16")]

     

    public string Products

     

     

    get  

     

     

     

     

     

    return this["Products"];

     

     


    But this doesn't seem to solve the problem. Next I tried to look if I created the error, so I've created a new project and imported the productCatalogSample directly from the SDK, but here I ran into the same problem. How can I fix this?

    With kind regards,

    Mark
  • Hi Systeembeheer UNIT4,

    This issue is fixed internally and will be shipped with the next SDK release. By the way, your first fix seems correct, but you will have to restart the server before trying it again.

    Basically, you have to open ProductsResources.cs, then add

    /// <summary>
    /// Title of the Products
    /// </summary>
    [ResourceEntry("Products",
        Value = "Products",
        Description = "Products",
        LastModified = "2011/05/26")]
    public string Products
        get
        
            return this["Products"];
        

    Then kill the server and launch it again.

    This should solve the issue.

    Greetings,
    George
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>