Can't run any of the samples in SDK - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Can't run any of the samples in SDK

  • Can't run any of the samples in SDK
  • 273388_sdk.PNG
    I give do you run/extract the samples in the SDK?  I've spent hours trying to figure it out.  All of the buttons on the samples are grayed out.  I've attached a screenshot. 

    On the bottom it says "Not Licensed".  I have multiple licenses and I can't for the life of me find where you upload a license file in the sdk.  I've tried dropping one of my license files in every directory possible in the sdk.  I've also uninstalled/reinstalled.  Am I crazy???
  • Hello Shawn,

    If  the SDK says that your copy is not licensed, please make sure to include your working Sitefinity License in the folder C:\SitefinitySamples\DatabaseData. Also please make sure that you use our latest official SDK release - SDK SP1, because it contains a lot of bug fixes. The system requirements for the SDK are the same as for Sitefinity which you can check in our website.

    Best wishes,
    Victor Velev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • Hi Shawn,

    Radoslav Georgiev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • This is crazy how difficult it is to extract the samples in the SDK.  I've wasted hours so far.  I've tried your suggestion and I've followed the steps outlined in this post:  Neither works.

    I did manage to get the SDK to display "licensed".  In the C:\Program Files\Telerik\Sitefinity 4.1\SDK\Telerik.Sdk.Browser.exe file I manually changed the license file path.

    <setting name="LicensingFilePath" serializeAs="String">

    But I still can't run or extract the samples...the buttons are still disabled.  I don't understand what I'm doing wrong.  Is it a bug in the SDK? 

    I know I have the latest version of the SDK because I re-installed it today.  I've tried 2 difference license standard and one professional.  I've even tried different license files for the two 4.1x builds. 

    Once I finally get this working are there instructions on upgrading the starter kits?  Have there been any changes since 4.0? 
  • Hello Shawn,

    It is possible that something is messed during the installation and the upgrade processes. I have discussed your case with a colleague of mine and he suggested that you remove all previous SF installations and install the new one again. I am doing an extensive research about the issue you are experiencing, but in the meantime you can try the solution proposed above.

    Kind regards,
    Victor Velev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • Unintalled and re-installed Sitefinity and the SDK but still no luck.  I even installed it on a fresh 64 bit Windows 7 VM and it didn't work.  Please advise.  Is there a way I can force those links to be active?  Possibly change another setting??

    Is there a way I can just extract the Charity starter kit manually? 
  • Hello Shawn,

    I have contacted with some colleagues of mine and we will have a deeper look at the issue.  In the meantime you can go to:

    C:\Program Files (x86)\Telerik\Sitefinity 4.1\SDK\Content\Samples\asp\CSharp

    where you can find the samples from the SDK.

    Victor Velev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • What is the recommended process to upgrade a starter kit?  I tried to follow these steps as closely as possibly:

    Here's the steps I took to "test" an upgrade but it's not working for me.

    1.  Backed up production website and database
    2.  Restored production db to local sql server instance
    3.  Opened C:\Program Files\Telerik\Sitefinity 4.1\SDK\Content\Samples\asp\CSharp\Charity in Visual Studio
    4.  Deleted configuration files (App_Data/Sitefinity/Configuration)
    5.  Copied configuration files from current production website (App_Data/Sitefinity/Configuration)
    6.  Change the connection string to the db restored in step 2
    6.  Recompile solution and ran ~/default.aspx

    According to the documentation using the config files from an older version of Sitefinity is supposed to trigger a schema upgrade.  The website just spins for a while and eventually times out after a few minutes.  I see some new entries in the config files referencing the lastest version of Sitefinity (4.1.1395.0) but some still point to the old version.

    The lack of documentation and apparent bugs is frustrating.  I still can't extract any of the samples from the SDK.  I have a production version of the charity starter kit running that I would like to upgrade.  Please advise on how to. 

    The upgrade log has all success messages.  The error log contains this message:

    Timestamp: 6/1/2011 4:05:33 AM

    Message: HandlingInstanceID: 3ff5f52d-9c47-46ee-b194-911e0a696b18
    An exception of type 'Telerik.Sitefinity.SitefinityExceptions.ItemNotFoundException' occurred and was caught.
    05/31/2011 23:05:33
    Type : Telerik.Sitefinity.SitefinityExceptions.ItemNotFoundException, Telerik.Sitefinity, Version=4.1.1395.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    Message : You are trying to access item that no longer exists. The most probable reason is that it has been deleted by another user.
    Source : Unity_ILEmit_DynamicClasses
    Help link :
    Data : System.Collections.ListDictionaryInternal
    TargetSite : Telerik.Sitefinity.Pages.Model.PageNode GetPageNode(System.Guid)
    Stack Trace :    at DynamicModule.ns.Wrapped_OpenAccessPageProvider_4149cfa499744c83bfc099f677e7d586.GetPageNode(Guid id)
       at Telerik.Sitefinity.Modules.Pages.PageManager.GetPageNode(Guid id)
       at Telerik.Sitefinity.Modules.Lists.ListsModule.InstallPages(SiteInitializer initializer)
       at Telerik.Sitefinity.Modules.GenericContent.ContentModuleBase.Install(SiteInitializer initializer)
       at Telerik.Sitefinity.Modules.Lists.ListsModule.Install(SiteInitializer initializer)
       at Telerik.Sitefinity.Services.ModuleBase.Install(SiteInitializer initializer, Version upgradeFrom)
       at Telerik.Sitefinity.Services.SystemManager.InitializeModule(ModuleSettings settings, InstallContext installContext, Boolean start)

    Additional Info:

    MachineName : xxxxxxx
    TimeStamp : 6/1/2011 4:05:33 AM
    FullName : Telerik.Sitefinity.Utilities, Version=4.1.1395.0, Culture=neutral, PublicKeyToken=b28c218413bdf563
    AppDomainName : /LM/W3SVC/2/ROOT-1-129513747068115152
    ThreadIdentity :
    WindowsIdentity : xxxxxxxx
    Requested URL : /

    Category: ErrorLog

    Priority: 0

    EventId: 9010

    Severity: Warning

    Title:Enterprise Library Exception Handling

    Machine: xxxxxx

    App Domain: /LM/W3SVC/2/ROOT-1-129513747068115152

    ProcessId: 4580

    Process Name: c:\windows\system32\inetsrv\w3wp.exe

    Thread Name:

    Win32 ThreadId:5812

    Extended Properties:

  • Hello Shawn,

    You can upgrade the starter kit by following these steps:

    1. Backup your files and database.
    2. Change the references ( add the new ones to the project ).
    3. Run the project.

    Adding the new references will automatically upgrade your project codebase and database.

    The error you get is possibly result of missing page or item related to the lists or content module. If this error is the result of the performed upgrade, please the steps I wrote above and try again. Also I would like to ask you if there is a specific reason for upgrading the starter kits, since it is most up - to date stable version.

    Victor Velev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • I figured out why I couldn't run the samples.  The VM that I installed the SDK on had VS 2010 Express installed.  Apparently, there is a dependency on a higher version of VS.  I didn't see it listed in the requirements of the SDK.  I'm not sure if this is a bug or an omitted requirement.  I installed the SDK on my work computer with VS Ultimate and it worked as expected.

    Is this a bug in the SDK? I can open the project fine using VS Express when I browse directly to the sample solution so I suspect it is a bug in the SDK. 
  • Hello Shawn,

    Glad to hear that your issue has been resolved.

    As a requirement you need Visual Studio ( standard edition and above ) installed ( we do not support Express editions ). This is not a bug, but seems that this section is a bit unclear. We will make sure that the the requirements are more descriptive so people do not experience such issues in future.

    Victor Velev
    the Telerik team
    Explore the entire Telerik portfolio by downloading the Ultimate Collection trial package. Get now >>
  • Hi Folks,

    I have the same issue and I cannot able to extract the startup from SDK 6.0 and seeking for help. I open a new thread to discuss it as well. Hopefully any expertise could give me an ideas how to get the startup kit up-and-running in default server. Assume all the enterprise license is activated, valid and fulfill all the system requirements, thanks.

    Thank you.