Unable to get Corporate and Real Estate Starter Kits to Run - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Unable to get Corporate and Real Estate Starter Kits to Run

  • Unable to get Corporate and Real Estate Starter Kits to Run
  • I was able to get the Education and Non-Profit Starter kits to run with no problems but when I click Run Sample in Browser on the Real Estate and Corporate starter kits, they are throwing the following error: Could not find a part of the path 'C:\Program Files\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\DATA\SitefinityCorporateStarterKit.mdf'. 

    As with the two successful starter kits, I pointed to a network SQL server and yet these fail.  What do I need to do to get these to run?

  • Hi Judy,

    My suggestion is to open the sample extraction folder and delete the folders of the projects which you are experiencing problems with. You also need to delete the projects databases created in the SQL Management Studio. Then please open the SDK browser again and view in browser the desired samples. They should run properly now.

    Sabrie Nedzhip
  • Unfortunately, the Corporate and Real Estate databases don't exist on the server so I can't delete them.  There is also nothing for those two projects in the Extraction folder.

    I have a feeling the problem somehow stems from the fact that the first time I tried to install those two starter kits, I did not have database creation rights on the network server I wanted them on and they both failed.  My database permission issue has since been rectified but it seems there's now a pointer  stuck pointing to the path I mentioned in my first post and that's where it continues to look for the database. After it throws the error saying it can't find the database, the SDK browser crashes.  Is there another way I can reset both the Real Estate and Corporate starter kits?

  • I was unable to open the Visual Studio solution from within the SDK as it threw the same error.  It occured to me that something went wrong the first time I attempted to set up these two starter kits and so I tried manually attaching the databases in SQL Management Studio.  That's all it took to fix it.  Thanks for your help!
  • Hello Judy,

    Can you please try to open the samples in Visual Studio and then open the DataConfig.config file which is located under the ~/App_Data/Sitefinity/Configurations folder in order to make sure that the connection string is set properly. Then please build the solution, run the project from Visual Studio and let me know about the result.

    Another option is to download the SDK samples from the github website. You can find a README.md file for each sample which provides additional information about the sample, as well as installation instructions.

    Sabrie Nedzhip

    DevCraft Q1'14 is here! Join the free online conference to see how this release solves your top-5 .NET challenges. Reserve your seat now!