Sitefinity.All, Feather, and NuGet - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Sitefinity.All, Feather, and NuGet

  • Sitefinity.All, Feather, and NuGet
  • If i look at what NuGet presents me as the dependencies for Feather, it shows the only one I have to worry about it NinJect and making sure I have the proper NinJect version.  So I went ahead and updated the Feather project in my 7.3.5620.0  version of Sitefinity.  Now when I run the application, I am getting an assembly bind error as follows:

     

    Could not load file or assembly 'Telerik.Sitefinity, Version=8.0.5700.0, Culture=neutral, PublicKeyToken=b28c218413bdf563' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)

     

    Now looking at one past post, I saw that October of 2014 it was mentioned that there was a dependency in Feather on the latest Sitefinity.  How can we match up our Feather version to the right version of Sitefinity?  Why is this not shown as the dependency in NuGet, it's done for NinJect, seems like the Telerik.Sitefinity.All could have a version dependency too.  I am in the middle of finalizing a large enterprise deployment for one half of the application, so I don't want to upgrade the core software at this point, what Feather version works for my Sitefinity.All version 7.3.5620.0?​

  • Hi Mariush - the NuGet server seems to not have that version available.  Any thoughts on where to get it?
  • Hi George,

    Feather 1.1.110 is the latest one compatible with Sitefinity 7.3.

    It is built against 7.3.5600, so you may need to configure assembly redirects from 7.3.5600 to 7.3.5620.

    Mariush

  • Hi George,

    My bad, it is Telerik.Sitefinity.Feather 1.1.110.0 - http://nuget.sitefinity.com/#/package/Telerik.Sitefinity.Feather

    Mariush