Integration Tests + 404 - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Integration Tests + 404

  • Integration Tests + 404
  • Hi

    Need some help. I'm trying to build integration tests for my custom module and I've follow the SF documentation ( When I run the SDK Integration web test runner, all the tests appear but when I run a test it fails with the following:

    'FixtureSetup' and 'FixtureTearDown' failed.  Fixture Setup service call failed with the following exception: Exception, The service response status code was: 404: NotFound. The url was: localhost/.../RunFixtureSetup

    When I browse to the above url - I get "Endpoint not found".
  • Hello,

    Most probably there is a problem with your versions of Sitefinity and the test runner.

    Please open a support ticket through your Telerik account in order to investigate your issue in deep.

    Svetoslav Manchev
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • I have a ticket in for this too, but wondered if you ever got this resolved and if it was anything common that you could share?
  • Yes, I did. It came down to one of two things.
    1. Download the latest MB Unit and ensure the two dlls in the documentation are in the your bin folder.
    2. The test runner is the SDK was likely an old version. I was given the test runner that Sitefinity team use themselves and that worked.

    That's it and good luck
  • Hrmn, they are giving me a different response in my ticket which I do not quite agree with.  The statement was made in my ticket that I cannot use the development server and it has to be ran through an IIS hosted site which contradicts their own documentation.

    At any rate I went ahead and setup the test site on IIS 7.5 and am still seeing the same exact error (just different domain url obiviously).  I also get a "Service: endpoint not found" error if I try to navigate via my browser.  I then went into advanced settings and set the service url for my site to ensure that there were no issues resolving, but still no luck there.

    I also then went to Galio/MB to grab the latest version of their stuff just in case....nope.
  • Try the attached test runner the SF team gave me. Maybe this will work.
  • Thank you so much for linking that file Earle.  Tests are running now.  The only thing I had to do was to go into the Telerik.WebTestRunner.Client.exe.config to setup the proper auth credentials.  

    The above was needed because the SDK version that I had with 6.2.4900 would ask for user/pwd along with the url to connect whereas this version posted in this thread only asks for the url.