Sitefinity Upgrade from 7.0.5100.0 to 9.1.6110 Errors - Front- & Back-End Development - Front- & Back-End Development - Progress Community
 Front- & Back-End Development

Sitefinity Upgrade from 7.0.5100.0 to 9.1.6110 Errors

  • Sitefinity Upgrade from 7.0.5100.0 to 9.1.6110 Errors
  • 1bcc541e-37c1-6deb-a958-ff0000446526_sitefinityerror.png

    I am trying to upgrade my Sitefinity site from 7.0.5100.0 to 9.1.6110. The upgrade works locally.

    My intention is to merge the upgraded site with the site on my server. I copied over .dll's and web.config changes. 

    When I try to load the server version of the site, I get this error message. (Screenshot attached) Does anyone have any suggestions? 

  • Hi Jack. Your error doesn't look clear. Can you please provide logs from App_Data/Sitefinity/Logs folder
  • Hi Victor,

    That's the weird thing; there was no logs produced for this.  There also isn't any other error messages. 

    Thanks for the reply!

  • I had the same issue, the code worked in my dev environment, and as soon as I moved it to prod it didn't.

    I found the issue to be the Telerik.OpenAccess.Config.dll missing from prod

    In dev I had installed the Sitefinity Program Manager, and when I upgraded the project, it added a reference to that file, but it the reference was to where Sitefinity program manger was installed (check the hint path in the proj file). So when you try to run on Prod without that Sitefinity program manager installed it gave this error. I fixed the issue by copying that file to where all the dlls were copied, changed the reference to that location, set copy local true, so when I built it would copy the file to the bin directory and the project would run.

    That took hours to track down, since there wasn't really any helpful error logging on the subject.

    Hope that fixes your issue also.

  • Hi Kris, I will try your solution and update this post if it works. Thanks for the suggestion!

  • I figured out a solution:

    1. I reverted my changes to both website and DB on the server side so that I could start fresh.

    2. I installed Telerik.Feather as a NuGet package. (This also automatically installs Feather.Core as well)

    3. I pushed the web.config, all dll's, and resource packages. (Make sure to change the path in web.config if you have IIS configured in there)

    4. I spun up the serverside site and it worked perfectly.

     

    It looks like the issue was that Telerik.Feather was not installed and that's why the error was occurring in the first place.

     

    If this works for anyone else, please share!