Missing Resource - WebResource.axd call returning a 404, and bombing AppDomain - Bugs & Issues - Bugs & Issues - Progress Community

Missing Resource - WebResource.axd call returning a 404, and bombing AppDomain

 Bugs & Issues

Missing Resource - WebResource.axd call returning a 404, and bombing AppDomain

  • Missing Resource - WebResource.axd call returning a 404, and bombing AppDomain
  • We are working with SiteFinity 4, hosted on DiscountASP.net.  On a irregular (less than 5 minutes between cycles with 5 editors working) schedule, we will see the following error logged to the Errors.log file:

    ----------------------------------------

    Timestamp: 1/15/2011 2:13:49 AM
        Message: This is an invalid webresource request.

       at System.Web.Handlers.AssemblyResourceLoader.System.Web.IHttpHandler.ProcessRequest(HttpContext context)
       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

        Category:
        Priority: -1
        EventId: 1
        Severity: Information
        Title:
        Machine: THEBEAST
        Application Domain: /LM/W3SVC/2/ROOT-3-129395257431489152
        Process Id: 3972
        Process Name: c:\windows\system32\inetsrv\w3wp.exe
        Win32 Thread Id: 8980
        Thread Name:
        Extended Properties:

    ----------------------------------------

    If we investigate in the web logs, we find this call:

    2011-01-15 02:13:49 172.27.41.70 GET /WebResource.axd d=p8clnff8LmQ_WksB8TlY33EzXQDw6XhSZQcm-lKumpMGlB7r88147nIUqByjox4i5-8zP0nF8OO6LLEeyjSki70SSE8wBgTM0ItyW1v6avD_V2Rhu9_Lnahp6D1W3XPojP8RkmonoACo4LNkpLo9ae51wlGyiSa-vWanM5QC5hHngL8CF7myvyVJ4Vyfx45R0&t=634306222809563743 8888 cssteam 172.27.40.199 Mozilla/5.0+(Windows;+U;+Windows+NT+5.1;+en-US)+AppleWebKit/534.10+(KHTML,+like+Gecko)+Chrome/8.0.552.237+Safari/534.10 404 0 0 170

    Which is a 404, looking for a resource.  If we decode the resource URL we get:

    pTelerik.Web.UI|Telerik.Web.UI.Skins.Sitefinity.ToolBar.rtbDropDownBg.png

    And if we open up Telerik.Web.UI with Reflector, this resource is indeed missing.

    Any way to stop this from cratering our work all the time?

  • Hi Chris,

    Thank you for contacting us. 
    I am really sorry to hear about this problem. Could you please provide us with a url to your web site, and tell us on which page it is happening? If you want to keep this in private, please open a support ticket.

    Thank you in advance. 

    Best wishes,
    Georgi
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items