Analytics setup gets stuck on Step 3 - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Analytics setup gets stuck on Step 3

  • Analytics setup gets stuck on Step 3
  • Hi,

    When I try to setup analytics, it seems to get stuck on step 3. I pick my account and then hit Save Settings button. It then seems to just sit there. I can choose the drop down again and hit the button over again and nothing seems to work.

    The Analytics config doesn't get created at all. Looking into it, I didn't set the permissions for Network Service on the App_Data folder.

    Can the silverlight wizard that you use be updated so that it brings back a Permission denied error, or something that would tell me what I'm missing?

    Thanks

    -Matt
  • Hello Matt,

    Have you updated your project recently? It is possible that during upgrade you have omitted to update the Telerik.Sitefinity.Analytics.xap file part of the ClientBin folder. If this doesn't help you can delete from your App_Data/Sitefinity/Configuration folder the AnalyticsConfiguration.config and DashboardPermissions.config files which will reset your Sitefinity application.

    Can you also check if there is any JavaScript error in Firebug?

    Please get back to us if the problem persists.

    Greetings,
    Georgi
    the Telerik team

  • After migrating our website I had the same issue with analytics getting hung up on step 3.
    Following the instructions above, I checked the configuration folder and sure enough both AnalyticsConfiguration.config and DashboardPermissions.config were missing. After copying over both files from the previous installation analytics is now up and running smoothly.
    Thanks,
    - Don
  • Hello Don,

    Thanks for sharing your experience. 
    We'll investigate why this happens anyway.

    Kind regards,
    Georgi
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • Seeing the same behavior in 9.1. Verified Analytics Client Id and Secret and receiving prompt for allow permissions (so I have internet access and correct URIs in Google Console), then back to the Configure Analytics page. After some searching came upon a few articles that sited the missing configurations. But, creating a new project did not yield  the DashboardPermissions.config, nor did attempting to register it yield any different results.

     

    Is this a bug or configuration issue? Is there another documented work around?