Custom Modules, 4.1 SP1 and Open Access - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

Custom Modules, 4.1 SP1 and Open Access

  • Custom Modules, 4.1 SP1 and Open Access
  • Hey all,

    I've placed this question into the ticketing system, but given my pretty large urgency to get an answer, I wanted to toss the question out in the forums to see if anyone out there has run into this in the SP1 upgrade.

    I'm attempting to upgrade custom modules from 4.1 (working) to 4.1 SP1 and cannot compile them.

    Error   81  Could not load file or assembly 'Telerik.OpenAccess.35.Extensions, Version=2011.1.411.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. General Exception (Exception from HRESULT: 0x80131500)
    ExceptionString:
    System.IO.FileLoadException: Could not load file or assembly 'Telerik.OpenAccess.35.Extensions, Version=2011.1.411.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' or one of its dependencies. General Exception (Exception from HRESULT: 0x80131500)
    File name: 'Telerik.OpenAccess.35.Extensions, Version=2011.1.411.2, Culture=neutral, PublicKeyToken=7ce17eeaf1d59342' ---> System.Exception: The referenced assembly 'C:\Sitefinity Projects\Q1 Projects\empty 4.1 SP1 project\bin\Telerik.OpenAccess.35.Extensions.dll' has the wrong version; expected Version=2011.1.411.2 but found Version=2011.1.510.1.
       at Telerik.OpenAccess.SPI.AssemblyProvider.LoadFromReferences(String assemblyName)
       at Telerik.OpenAccess.SPI.AssemblyProvider.RefResolveEventHandler(Object sender, ResolveEventArgs args)
       at System.AppDomain.OnAssemblyResolveEvent(RuntimeAssembly assembly, String assemblyFullName)
       at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMarkHandle stackMark, Boolean loadTypeFromPartialName, ObjectHandleOnStack type)
       at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName)
       at System.RuntimeType.GetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)
       at System.Type.GetType(String typeName)
       at Telerik.OpenAccess.Sdk.Enhancer.Enhancer.CrossDomainRunImpl(AssemblyLoader assemblyLoader)
       at Telerik.OpenAccess.Sdk.Enhancer.EnhancerBase.CrossDomainRun()
     
        C:\Sitefinity Projects\Q1 Projects\OTTA Dev 4.1\Glossary Module\obj\Debug\GlossaryModuleProject.dll GlossaryModuleProject

    I've checked and rechecked my references, created empty projects to use as DLL reference pointers, tried the _Empty Project as a pointer that was created, etc.  So I know I have the right DLLs in play.  Still, 35Extensions fail.

    Has anyone run into this while performing the upgrade to SP1?  If so, how did you get past it?

    Thanks much
    - William
  • Alas, we are experiencing the same problem.

    OK, folks, this isn't funny anymore. As a company who has been strongly recommending the Sitefinity product for years now, we are no longer able to do so with any confidence. 3.x was such a solid performer, and if a bug did appear, it was addressed quickly by the responsive and capable development team. Now, with 4.0, we get unofficial "internal builds" that do nothing to help us deliver projects, and have to wait weeks to get fixes to show-stopping bugs.

    We have been wrestling with custom modules - more specifically, with OpenAccess in custom modules - for the past several months now. We like change - really, we do - but when a solid product is "upgraded" to a new version, it has to work. And, 4.x doesn't - at least not outside of a lab. If feels as if stability and maintainability were traded in for a new whiz-bang framework/programming model.

    Sigh... Please guys, take a long, hard look at your road map and decide whether it makes more sense to retain your loyal customers, or to shoe-horn in more bells and whistles at the expense of fixing the existing issues. Unless your product "just works" and is easily extensible, the new-world-order Sitefinity no longer looks significantly more attractive than it's competition.

    I know everyone is working hard at Telerik to try to keep up with issues. But, we are now unable to deliver on promised features that would have been trivial in 3.x.

    Regards,
    John
  • I too am facing the same problem!! This is totally ridiculous!!
  • me too, had this issue.. anyone got workaround?
  • Hello All

    I was running into this issue.  The cause of the issue was that my Telerik .dll files the \bin folder were being replaced with older versions when I would compile my solution.

    In my solution, I have two projects: one for the website and another for a module.  I found that if I unloaded the module project from my solution and then recompiled, the Telerik .dll's in my \bin folder of the website project were no longer replaced.  I am now able to run my website.

    I have not diagnosed the cause of the .dll's being replaced previously, but it seems that it is related to how I have my projects setup in Visual Studio and how my module project is referencing the .dll's in my website project.

    Hope this helps.
  • Actually, Antoine, I tried that as well and there's more to it than that because the module will still fail to compile when using Open Access and including an older version of the module's dll will bring down your upgraded Sitefinity 4 SP1. There's a definite dll mismatch here that needs to be resolved for anyone using Open Access based custom modules.
  • Hey all,

    The DLL mismatch is caused by outdated SDK files.  I was given updated files for things like Venhance.exe through the ticketing system and have managed to complete a compile of my modules.  If you are running into those issues, I'd suggest asking Telerik through a ticket. 

    - William
  • That is correct, The venchance.exe use's the pre SP1 version of OpenAccess extensions. Can we not make this part of the empty project distribution?

    I am in the situation where I have to have this done today, but now I have to wait 48 hours for them to send it via a ticket.
  • I'm having the same problem. Just to be sure I understand correctly. We need to request specifically from Telerik the updated file venchance.exe?

    Isn't there a link to download this?

    Antoine, you were saying that is working for you. If unloaded the project, reloaded but still the same error.

    Is there anything else you did?

    Thank you!
  • I submitted a ticket this morning and have gotten the file already... but yes, the current sdk version of venhance.exe has a dependency on the previous version of OpenAccess.
  • Thank you John. I'll request now one myself. I hope I'll get it fast.

    Please tell me if this resolved entirely the problem.

    Thank you!
  • I am now able to compile the modules, you will have to edit the project file in a text editor and change the key
    <OpenAccessPath>$(registry:HKEY_LOCAL_MACHINE\SOFTWARE\Telerik\SitefinitySDK\@LibrariesDir)</OpenAccessPath>

    to the path where you placed this new file. (ex. <OpenAccessPath>..\..\..\Library\4.1.1395.0\</OpenAccessPath>)

  • I noticed that the Sitefinity SDK 4.1 SP1 Installation Package is now available for download.

    I have not yet tried installing it, but I imagine this will relieve the issues.
  • Yes, this should update the sdk on your machine and not require you to update the project file manually.