page not found error for external pages - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

page not found error for external pages

  • page not found error for external pages
  • Hi,

    I keep getting this error when I create an external page in sitefinity:

     Server Error in '/' Application.
    Page not found
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.


    Exception Details: System.Web.HttpException: Page not found


    Source Error:


    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:


    [HttpException (0x80004005): Page not found]
       Telerik.Sitefinity.Web.PageRouteHandler.handler_PreRenderComplete(Object sender, EventArgs e) +1132
       System.EventHandler.Invoke(Object sender, EventArgs e) +0
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4543

     

    Thanks,
    Annie
  • Hi Annie,

    Can you tell us more of your setup? How do you set the external page? Additional information such as steps or way to reproduce the problem would be extremely helpful to us, so we can give you an advice how to proceed on fixing the problem.

    Kind regards,
    Victor Velev
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • 362749_pnf.png
    I'm getting the same error when I link Detail View of a Dynamic Content to another page within sf.
    Details in following post: 
    http://www.sitefinity.com/devnet/forums/sitefinity/bugs-issues/custom-detail-page-for-dynamic-module-not-found-routing-problem.aspx

    Regards
    Bostjan
  • I'm getting the same error when I link Detail View of a Dynamic Content to another page within sf.
    Details in following post: 
    http://www.sitefinity.com/devnet/forums/sitefinity/bugs-issues/custom-detail-page-for-dynamic-module-not-found-routing-problem.aspx

    Regards
    Bostjan
  • Don't know if this is already solved, but otherwise you could try to insert this on the Page_Load event of your control:

    Telerik.Sitefinity.Web.RouteHelper.SetUrlParametersResolved(true);

    Regards,
    Daniel

  • Hi,

     Thank you for your suggestion and help for the community. I would also like to add this blog post we've released on the topic, when we implemented this functionality, as a reference to anyone else who stumbles upon this thread.

    Kind regards,
    Patrick Dunn
    the Telerik team
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items