[5.0] Issue SSO claim authentication - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

[5.0] Issue SSO claim authentication

  • [5.0] Issue SSO claim authentication
  • Hi,

    I follow strictly your configuration to setting sso with claim authentication: www.sitefinity.com/.../setting-up-sso-with-claims-based-authentication  (see also the video: www.youtube.com/watch

    Example:
    First site: http://site1.domain.com
    Second site: http://site2.domain.com

    I receive the good url when I want to log to the site2

    site1.domain.com/.../SWT

    But I receive this error when I push on the button "login":

    Missing configuration for the requesting relying party "http://site2.domain.com"

    How can I resolve this issue?
  • I don't why...but it's now resolve...sorry for this thread...

  • I got the same error message but it went away after doing an IIS Reset. I wasn't using SSO.
  • Same problem here (SF5.0, no SSO) when logging into Sitefinity backend. What does it mean and how can I fix it (resetting IIS didn't work for me)?

    Note: I thinks it has something to do with your login widget and SSL enabled on certain pages. I cannot yet figure out what the issue exactly is...

    The message: Missing configuration for the requesting relying party https://site.domain.com

    Can you help me?
    Thanks in advance. 


  • I think I figured it out when it goes wrong. See the following scenario:

    One of my testsites needs a login, so the default page is:
    https://site.domain.com/login

    When I replace the "login" page through the backend link:
    https://site.domain.com/sitefinity

    I am redirected to:
    site.domain.com/.../SWTs%3a%2f%2fsite.domain.com%2f&redirect_uri=%2fsitefinity&deflate=true

    Mention the realm (https instead of http) parameter in the url!

    When I try to login I get the following error:
    Missing configuration for the requesting relying party https://site.domain.com

    So, because my backend hasn't got SSL yet, I probably get the message. Maybe you can do something with this information?

    Thanks in advance.

    Regards,
    Peter
  • I was running in to this recently while trying to lock down the backend login page with SSL. I couldn't find any documentation from Telerik that this is required, but I resolved this error by adding that full value (in the last reply's case, https://site.domain.com) to the <relyingParties> node, which is right below the <securityTokenIssuers> node.
  • Hello,

    Thank you for sharing the information with the community.

    Regards,
    Stefani Tacheva
    Telerik
    Do you want to have your say in the Sitefinity development roadmap? Do you want to know when a feature you requested is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  • In my case, i was having issues when i tried to access to the backend using http. Sitefinity redirected me to https and when i typed my credentials, i was getting the error: Missing configuration for the requesting relying party https://site.domain.com

     I added the security token issues and it didnt fixed. What  have to do was:

    in web.config, i changed the wsfederation line:

    <wsFederation passiveRedirectEnabled="true" issuer=http://localhost realm=https://Sitefinityxxxx.domain.com requireHttps="true" />
            <cookieHandler requireSsl="false" />

    I have to add the S to http and use the fqdn of  the server. After this change, i was able to login with http redirection and https. 

     

     

  • Strangely this error started happening yesterday on our test server even though we didn't make any changes to the security or authentication configuration. Adding the full domain name to the realm attribute of the <wsFederation> element fixed the problem.