404 Returned Immediately after Login - Bugs & Issues - Bugs & Issues - Progress Community
 Bugs & Issues

404 Returned Immediately after Login

  • 404 Returned Immediately after Login
  • We have a project running on Sitefinity 7.1, which we've been running for years (since 4.x) and haven't had this issue before. 

    Recently I upgraded to Windows 10, configured IIS to have all the right Handlers etc. as per Progress's recommendations and I get to the point where the site runs successfully. 

    The problem is on the backend. When I browse to /sitefinity it correctly redirects me to dev.customer.com/.../Login (note: dev.customer.com is based on an entry in my hosts file). 
    I enter my credentials and click login after which it redirects me back to /sitefinity and throws a 404 error

    If however I manually add /Pages behind /Sitefinity, it correctly displays the pages backend page. I can edit and publish/save pages, news items and blogs, etc. So the problem seems specifically related to the /Sitefinity page. If I manually add a '/' behind /Sitefinity it correctly redirects me to the dashboard page. 

    The only thing I can think of is that one of my rewrite rules are causing this issue. Here are my rules: 

    <rewrite>
      <rules>
        <rule name="LowerCaseRule1" stopProcessing="true">
          <match url="^(Sitefinity/)" ignoreCase="true" negate="true"/>
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="URL" pattern="[A-Z]" ignoreCase="false"/>
            <add input="URL" pattern="\.axd" negate="true"/>
            <add input="URL" pattern="\.xamlx" negate="true"/>
            <add input="URL" pattern="\.ashx" negate="true"/>
            <add input="URL" pattern="\.asmx" negate="true"/>
            <add input="URL" pattern="\.xap" negate="true"/>
            <add input="URL" pattern="bundles" negate="true"/>
            <add input="URL" pattern="/App_Themes" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="SFRes" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="RestApi" negate="true"/>
          </conditions>
          <action type="Redirect" url="ToLower:URL" redirectType="Permanent"/>
        </rule>
        <rule name="RemoveTrailingSlashRule1" stopProcessing="true">
          <match url="(.*)/$"/>
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="REQUEST_FILENAME" matchType="IsDirectory" negate="true"/>
            <add input="REQUEST_FILENAME" matchType="IsFile" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="(.*?)\.svc$" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="bundles" negate="true"/>
          </conditions>
          <action type="Redirect" url="R:1"/>
        </rule>
      </rules>
    </rewrite>

    Final note: On our production server this issue doesn't exist , which is Windows Server 2012 Standard/IIS 8.0

    Any help would be appreciated