404 Not Found for Backend Template Thumbnails - Bugs & Issues - Bugs & Issues - Progress Community

404 Not Found for Backend Template Thumbnails

 Bugs & Issues

404 Not Found for Backend Template Thumbnails

  • 404 Not Found for Backend Template Thumbnails
  • I don't see my template thumbnails any more and looking at Firebug I noticed this error: 

    "NetworkError: 404 Not Found - dev.mysite.com/.../custom.png

    Could this be because of something I'm missing in my rewrite rules? 

    <rewrite>
      <rules>
        <rule name="LowerCaseRule1" stopProcessing="true">
          <match url="^(Sitefinity/)" ignoreCase="true" negate="true"/>
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="URL" pattern="[A-Z]" ignoreCase="false"/>
            <add input="URL" pattern="\.axd" negate="true"/>
            <add input="URL" pattern="\.xamlx" negate="true"/>
            <add input="URL" pattern="\.ashx" negate="true"/>
            <add input="URL" pattern="\.asmx" negate="true"/>
            <add input="URL" pattern="\.xap" negate="true"/>
            <add input="URL" pattern="bundles" negate="true"/>
            <add input="URL" pattern="/App_Themes" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="SFRes" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="RestApi" negate="true"/>
          </conditions>
          <action type="Redirect" url="ToLower:URL" redirectType="Permanent"/>
        </rule>
        <rule name="RemoveTrailingSlashRule1" stopProcessing="true">
          <match url="(.*)/$"/>
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="REQUEST_FILENAME" matchType="IsDirectory" negate="true"/>
            <add input="REQUEST_FILENAME" matchType="IsFile" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="(.*?)\.svc$" negate="true"/>
            <add input="REQUEST_FILENAME" pattern="bundles" negate="true"/>
          </conditions>
          <action type="Redirect" url="R:1"/>
        </rule>
      </rules>
    </rewrite>

  • I'm having the same issue, was there a fix to this?
  • Hi Tim, 

    In our case it was a rewrite rule causing the problem. Specifically the lowercase rule. 

    We added in the following condition which solved our problem: 

    <add input="URL" pattern="/images/SystemLibrariesProvider/" negate="true" />

     

    Here's our complete rule now: 

    <rule name="Nedoweb - LowerCase Rule" stopProcessing="true">
          <match url="^(Sitefinity/)" ignoreCase="true" negate="true" />
          <conditions logicalGrouping="MatchAll" trackAllCaptures="false">
            <add input="URL" pattern="[A-Z]" ignoreCase="false" />
            <add input="URL" pattern="\.axd" negate="true" />
            <add input="URL" pattern="\.xamlx" negate="true" />
            <add input="URL" pattern="\.ashx" negate="true" />
            <add input="URL" pattern="\.asmx" negate="true" />
            <add input="URL" pattern="\.xap" negate="true" />
            <add input="URL" pattern="bundles" negate="true" />
            <add input="URL" pattern="/App_Themes" negate="true" />
            <add input="URL" pattern="/images/SystemLibrariesProvider/" negate="true" />
            <add input="REQUEST_FILENAME" pattern="SFRes" negate="true" />
            <add input="REQUEST_FILENAME" pattern="RestApi" negate="true" />
          </conditions>
          <action type="Redirect" url="ToLower:URL" redirectType="Permanent" />
    </rule>

     

    If that's not the cause of your issue, here's some advice from the guys at Progress: "Based on our experience this issue may occur if the Url Root for the images has been changed. Can you please log in the Sitefinity backend and go to Administration -> Settings -> Advanced Settings -> Libraries -> Images and check what is the value entered in the Url Root field. By default it is set to "images". Can you please check this and let me know what the URL root is on your side? What I assume is that the URL root has been changed to a value different than "images" but the page template thumbnails are still being loaded using the old URL root and thus they cannot be resolved."

    Hope that helps.

  • Hi Tim, 

    Did that help? 

    Regards,
    Jacques

  • No, unfortunately our case was a bit different. We were getting all of the same errors but I was able to resolve the issue by going to the page templates ->  actions -> properties then change template thumbnail from there I just re-selected the default thumbnail and this fixed the issue. I'm still not sure what caused this issue?

    Thanks for the reply though.