Changing Field Definition doesn't apply to API (SOAP) server - Forum - Rollbase - Progress Community

Changing Field Definition doesn't apply to API (SOAP) server


Changing Field Definition doesn't apply to API (SOAP) server

  • We had a bug in one of our formulas that was preventing a SOAP call from succeeding due to a formula error. So I fixed the formula by modifying it using the "Edit" field definition. Once I corrected the formula, it worked correctly if I viewed the record directly in the UI. However, when I tried to update that same record using a SOAP call, I would still get the original formula error, as though the new field definition had not been rolled over to the API server. When we were having this issue, the customer was already loaded on both the PROD and SOAP server. So I wrote a little JSP script to unload the customer from the SOAP server, and once I did that and tried the SOAP call again, it worked perfectly. So it seems like there is a cached version of field definitions that is not updated on the SOAP server when a change is made on the UI server if the same customer is loaded in both places. Also, on that same note, is it possible we could have a UI button to unload customer from the API server? It
  • Hi Kurt,

    Changes to certain field definitions are not reflected in SOAP/REST servers due to caching mechanism. This is discussed in the documentation.

    Such updates will take into affect after the next Rollbase maintenance event (or

    Tomcat restart for Private Cloud customers).

    I submitted enhancement request CR # PSC00110393 to add a UI button to unload customer. Our product management team will review this CR and consider it for a future Rollbase release.

    Thank You,


    Progress|Rollbase Product Support Team