Tomcat apache fails to start on microsoft SQL server installation - Forum - Rollbase - Progress Community

Tomcat apache fails to start on microsoft SQL server installation


Tomcat apache fails to start on microsoft SQL server installation

  • I have followed the setup instructions and made adjustements to use SQL SERVER as the backend. My colleague has followed the video and had no trouble setting up MySQL installation. My knowledge of Apache and Java is very limited, I warn you. After installing the apps files, I go to tomcat\bin and type startup.bat at a command prompt. The server seems to try to start but the lock up. I have looked in the tomcat logs but they give no clue what is happening. I put the ms jdbc driver into the tomcat\bin folder. I have set the environment variables jre_home, rollbase_home and rollbase_root. The latter are both set to tomcat\rollbase, the former points to the jre6 folder. I am running windows 2008 R2 64 bit with SQL server 2008. JAVA SE 6U31, tomcat 6. Can anyone advise what to check next? See screen shot which shows status after running startup.bat. Thanks
  • I have to admit that SQL Server installation is least tested case. I will do some testing and come back to you on this.
  • May be Martin knows more -I know his team runs Rollbase on SQL Server.
  • As Pavel mentioned, SQL Server is supported but is the least used and therefore least tested option since most of our customers run on MySQL or Oracle. However, this does not mean the problem necessarily lies with SQL Server.

    From your screenshot it looks like Tomcat stops responding after the Master Server component is started. Perhaps this is due to a problem in configuration. After the Master component starts are you able to access the monitor page.

    In your configuration it should be at the following URL for you:


    If you can access this can you post a screenshot of the result?

    Also, can you look in your rollbase Files folder for the AllErrors.log file? This should be in the "Files" sub-directory called "1" or "2".
  • Please make sure you have sqljdbc.jar is placed in CATALINA_HOME/lib directory.

    I'm almost sure that was the reason.

    I also will check why the system did not display meaningful error message, as well as update documentation and emphasize that JDBC drivers are not part of Rollbase Private Cloud binaries.

  • Unfortunately, I wasn't there in person when we created one of our private instances running on MSSQL, i will contact our infrastructure team to clarify your concerns.

    Piscoso, Martin

    Rollbase PH
  • Thanks for the quick responses.

    I have placed sqljdbc.jar in catalina_home and catalina_home/lib.

    The monitor does not start up - page just sits trying to load but I get no response.

    There is no files folder under rollbase.

    The Ms article mentions setting classpath but htis gets overridden when the startup.bat file is run and ends up as "Using CLASSPATH: c:\tomcat\bin\bootstrap.jar".

  • hi orbisrb,

    - pls. rollback all the default config and try the inputs below. I already tested and it work in my private host.

    Here's what we do in setting up MS-SQL connections.

    - place the "sqljdbc4.jar" in \tomcat\lib not in ..\bin directory

    In Database.xml under ../rollbase/config directory.. I used the following script to connect to MS-SQL Database Server.

    NOTE: make sure that user account is properly setup in MS-SQL engine. I suggest to test first the DB user account in MS Management Studio.

    hope this helps..
  • I'll do some more testing and update binaries tonight.
  • Hi and thanks for all your help.

    I have put jdbc and jdbc4 .jar files into tomcat\lib and \bin folders.

    I double checked the config files and did check that I could log in with the given credentials.

    I noticed that when I run startup.bat the CLASSPATH is set to tomcat\bin\bootstrap.jar. Microsoft suggest that classpath should have the jdbc.jar on it. Am I correct in assuming that bootstrap.jar will also allow other classes to be loaded?

    Once I have downloaded and re-installed the rollbase files I started tomcat and went to the login.jsp page. This loaded successfully but when I enter the username and password and hit enter it complains that it cannot load jdbc driver.

    Here is a sample of the log file which is produced during startup: -


    29-Mar-2012 11:20:43 org.apache.catalina.core.StandardContext loadOnStartup

    SEVERE: Servlet /master threw load() exception

    com.rb.util.db.a404: Cannot load JDBC driver com.microsof
  • That's what I suspected from the beginning: JDBC driver for SQL Server cannot be loaded.

    Please try to copy sqljdbc.jar on Tomcat/lib directory (and remove sqljdbc4.jar).
  • I have already copied sqljdbc.jar to tomcat\lib. I have now tried removing the sqljdbc4.jar and this makes no difference.

    I then tried moving jdbc.jar to tomcat\bin. Same result.

    I really feel it is to do with classpath not being set as directed by Microsoft. Does bootstrap.jar load the jdbc drivers. It seems classpath is set to bootrap.jar only by some part of the process in startup.bat. I notice there is a setclasspath.jar but this does not actually mention the classpath.
  • Have you changed your databases.XML ? As mentioned by waltz
  • yes indeed. I follow all instructions.
  • Hi Nick,

    Pavel has just left for Japan on holiday until April 17th so this is unfortunate timing in solving your issue. While I believe he had no issues setting this up on his side, he won't be available to answer your questions on this until later in April. I am hoping either one of our development partners can help you get past this issue in the forums, or I can identify the problem in my tests here [planning to set up a new test instance using SQL Server shortly]. I will let you know if I run into the same issue.

    Meanwhile please let me know if you make any progress. I know that some folks at our Philippines partner run Rollbase Private Cloud on SQL Server and havn't run into this (that I know of) so perhaps they can jump in here or connect with you. We can find a way to reward them I'm sure :)