New laptop Installation Not Creating First User (I do not get the initial email) - Forum - Rollbase - Progress Community

New laptop Installation Not Creating First User (I do not get the initial email)

 Forum

New laptop Installation Not Creating First User (I do not get the initial email)

  • New laptop Installation Not Creating First User (I do not get the initial email) I cannot complete Rollbase installation. I do not get the install email. I have tried this on two different machines. Please see the output from the different log files below - the one at the end tomcat6-stdout.2012-01-30 contained errors. Thank you. Robert Burrage localhost.2012-01-30 Jan 30, 2012 7:59:05 PM org.apache.catalina.core.StandardContext loadOnStartup SEVERE: Servlet /master threw load() exception com.rb.core.data.a73: Object definition for USER object not found at com.rb.core.data.user.a114.create(a114.java:630) at com.rb.core.data.user.a114.createGuestAccount(a114.java:970) at p25.a336.checkInstallation(a336.java:77) at com.rb.master.logics.servlet.Starter.init(Starter.java:60) at javax.servlet.GenericServlet.init(GenericServlet.java:212) at org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1206) at org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:10
  • It looks like application XML files are missing when you start Tomcat first time. Please check ROLLBASE_HOME/apps/*.xml files. These files are part of rollbase.zip file.



    I recommend that you re-create database before first Tomcat start.
  • The xml files were seen to be present on the laptop computer.





    I tried again on the vm computer - I uninstalled all items refd in chapter 18 and reinstalled. I restarted tomcat from the command line. This failed again on the vm - I did not get the initial email for the vm. I have pasted the vm tomcat restart command line error messages below.





    I have been trying to install rollbase since 1/27/2012 without success. 2 other current co-workers have the same problem, and 2 previous ones also. I cannot speak for their error messages/issues in their case, but the installation would seem to be tricky. Any help would be appreciated.



    VM ERROR MESSAGES FOR TOMCAT RESTART

    C:\Tomcat\bin>tomcat6

    Jan 31, 2012 1:20:45 PM org.apache.catalina.core.AprLifecycleListener init

    INFO: The APR based Apache Tomcat Native library which allows optimal performanc

    e in production environments was not found on the java.library.path: C:\Tomcat\b

    in;C:\Windows\Sun\Java\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32;C
  • Are you running Tomcat as Windows service? It is strongly recommended that you run it first time as stand-alone application.



    I'm unaware why Windows Service may skip apps installation. Installation should began if two conditions are met:

    1. No user accounts created yet in RB_USER_DATA table

    2. App XML files can be found on ROLLBASE_HOME/apps directory.



    I'll investigate further in my environment.
  • On VM machine some rollbase files had been installed in the wrong folder - this was fixed by; also CLASSPATH was removed from env vars - the removal was done because of chapter 18. Doing these 2 steps got this failed installation to the point of an error message that I have seen for 2 prior failed installations: "com.rb.core.data.a73: Object definition for USER object not found" - full error message details are below. I am still stuck. Thank you. Robert Burrage



    ==>> Master Server is starting

    ROLLBASE_ROOT=C:\Tomcat\rollbase

    Host name: localhost:8080



    ==>> Installing local Rollbase instance

    Creating Master Zone: system records

    Rollback transaction #1 in thread 1 due to com.rb.core.data.a73: Object definiti

    on for USER object not found

    com.rb.core.data.a73: Object definition for USER object not found

    at com.rb.core.data.user.a114.create(a114.java:630)

    at com.rb.core.data.user.a114.createGuestAccount(a114.java:970)

    at p25.a336.checkInstallation(a336.java:77)

    at com.
  • I would strongly recommend that you rub Tomcat as stand-alone application, not Windows Service.
  • =>> Installing local Rollbase instance

    Creating Master Zone: system records



    In between the system must install standard apps. Perhaps they're not available (stored in wrong folder).



    I will modify installation procedure to check:

    1. That standard apps are available

    2. That Tomcat is running as stand-alone app



    Perhaps that would give users more relevant error messages.
  • (REF ERROR: VM machine ==>> Installing local Rollbase instance Creating Master Zone: system records Rollback transaction #1 in thread 1 due to com.rb.core.data.a73: Object definition for USER object not found - see earlier post)





    REF RB "Are you running Tomcat as Windows service?" - no, command line start e.g cd C:\Tomcat\bin then tomcat6





    REF RB "RB_USER_DATA table" - doing SELECT * FROM rb_dbo.RB_USER_DATA; shows 0 rows - it is empty





    REF RB "C:\Tomcat\rollbase\apps" - the following files are seen:

    01/31/2012 01:00 PM 562,364 app1_rb.xml

    01/31/2012 01:00 PM 338,407 app2_org.xml

    01/31/2012 01:00 PM 477,152 app3_sys.xml

    01/31/2012 01:00 PM 414,528 app4_isv.xml

    01/31/2012 01:00 PM 246,094 app5_supp.xml

    01/31/2012 01:00 PM 61,414 app6_appr.xml

    01/31/2012 01:00 PM 812,652 app7_crm.xml

    7 File(s) 2,912,611 bytes





    question: ref "In between the system must install standard apps. Perhaps they're
  • ROLLBASE_ROOT=C:\Program Files (x86)\Apache Software Foundation\Tomcat 6.0\rollbase



    Not c:\Tomcat\rollbase



    Set Windows environment variable

    ROLLBASE_ROOT=C:\Tomcat\rollbase
  • I am seeing the same problem;

    ==>> Installing local Rollbase instance

    Creating Master Zone: system records

    Rollback transaction #1 in thread 1 due to com.rb.core.data.a73: Object definition for USER object not found

    com.rb.core.data.a73: Object definition for USER object not found

    at com.rb.core.data.user.a114.create(a114.java:630)



    despite having;

    mysql> select * from RB_USER_DATA;

    Empty set (0.00 sec)

    mysql> quit



    and



    [root@50-5699-7678 bin]# ls -lah $ROLLBASE_ROOT/apps

    total 2.9M

    drwxr-xr-x 2 tomcat root 4.0K Jul 2 2011 .

    drwxr-xr-x 8 tomcat root 4.0K Feb 4 11:54 ..

    -rw-r--r-- 1 tomcat root 550K Oct 8 13:15 app1_rb.xml

    -rw-r--r-- 1 tomcat root 331K Oct 5 20:35 app2_org.xml

    -rw-r--r-- 1 tomcat root 466K Oct 11 16:34 app3_sys.xml

    -rw-r--r-- 1 tomcat root 405K Oct 11 16:35 app4_isv.xml

    -rw-r--r-- 1 tomcat root 241K Oct 11 16:43 app5_supp.xml

    -rw-r--r-- 1 tomcat root 60K Oct 6 20:16 app6_appr.xml

    -rw-r--r-- 1 tomcat root 794K Oct 6 19:10 app7_crm.xml





  • I found the issue, please try again after I'll update binaries later today. Sorry for all the troubles.
  • tomcat7-stderr.2012-02-06 shows errors of the form "SEVERE: IOException while loading persisted sessions: java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.rb.core.ui.web.a318

    java.io.WriteAbortedException: writing aborted; java.io.NotSerializableException: com.rb.core.ui.web.a318", and also a Apache Tomcat Native library warning --- full details below





    FYI this error happens everytime that Tomcat is started --- rollbase was finally installed ok --- I can login and re-login to rollbase --- there are no obvious issues seen so far in rollbase now-installed but we are seeing the error below in the logs whenever Apache is restarted, and error is being raised presumably by the rollbase code ("com.rb.core.ui.web.a318") for some unknown reason ---





    no other problems or issues seen so far about from this error in the logs --- FYI the 2/4/2012 rollbase deployment fixed the USER error preventing rollbase install.







    tomcat7-stderr.2012-02-06







    2012-02-06 09:45:48 C
  • The error "Object definition for USER object not found" on rollbase install attempt failure may possibly be fixed by new rollbase deployment file set timestamped 2/4/2012 (see my thread "http://getsatisfaction.com/rollbase/topics/new_laptop_installation_not_creating_first_user_i_do_not_get_the_initial_email" comment by PV near end) - downloading all rollbase files again fixed the issue for me (but see my thread for additional comments at end). Robert Burrage
  • The rollbase install attempt failure error "Object definition for USER object not found" was fixed for me by downloading all rollbase install files again to get the 2/4/2012 fix; rollbase install now works but I do see a new error in the logs (see end of thread for details). Robert Burrage
  • Please disable persistence (serialization) of Tomcat sessions to get rid of these errors. That do not affect Rollbase, however.