RB Private Cloud: Can I disable the safety precaution functionality when deleting an application? - Forum - Rollbase - Progress Community

RB Private Cloud: Can I disable the safety precaution functionality when deleting an application?

 Forum

RB Private Cloud: Can I disable the safety precaution functionality when deleting an application?

This question is answered

Is there a way to disable the feature that requires me to wait for an hour before I can delete an application?
I am using RB Private Cloud, so I am wondering whether I could put this to 30 minutes (test) or 0 minutes (development) for my environments. 
See screenshot below:

Verified Answer
  • You can use the "deleteApplicationDef" REST API. This API deletes the application immediately.

    documentation.progress.com/.../

    The other option is you can add the following property to shared.properties file. This can enable the Delete button after undeploy the application.

    ShowDebugInfo=true

    Restart the server after adding above property.

    Thanks

    Srinivas

All Replies
  • You can use the "deleteApplicationDef" REST API. This API deletes the application immediately.

    documentation.progress.com/.../

    The other option is you can add the following property to shared.properties file. This can enable the Delete button after undeploy the application.

    ShowDebugInfo=true

    Restart the server after adding above property.

    Thanks

    Srinivas

  • Thanks for your answer Srivinas, but when I try to use that, the API returns the following error:

    "Application ID with original ID null not found"

    In screenshot below you can see that I am adding the appId parameter:

  • Never mind, I had to add appId to the Query Parameters instead of the Header Parameters.

    After doing that, deletion completed succesfully:

  • However....after I used this (and supposedly everything was removed succesfully), I am no longer able to re-import the 'same' application XML. Now I get the following error, which suggests either something was (not) removed that should('nt) have been removed. (I also restarted my Rollbase instance, but same result):

    CRM TBC_v3.xml

  • Hi Ruben,

    There seems to be an issue in one of the reports.A defect has been logged for the same (defect Id : 74846).

    Thanks for reporting. We'll let you know the fix release for this.

    Regards,

    Shivani.

  • Ok, thanks Shivani!