Language / Date & Time-format - Forum - Rollbase - Progress Community

Language / Date & Time-format

 Forum

Language / Date & Time-format

This question is not answered

In PrivateCloud 4.4 i have this two lines in shares.properties:

# Default language code
DefaultLangCode=no
# Default date format index
DefaultDateFormat=0

Can anyone tell me wich alternative DateFormats thats exists?

When i login in the default language is still English....?

Default dateformat is "04/21/2017", but should have been "21.04.2017"

Default timeformat  is "10:00", but should have been "10.00" (dot instead of colon)

Why??

When I trye to get a timevalue ex:

var start="{!starttime#text}";

I get this in th correct value: "10.00" ("dot"), but when i try to set this value I need to use colon. Ex:

start = start.replace(".", ":");

TL["fromtime"]=start;

var newTLId = rbv_api.createRecord("timelines", TL);

What am i missing??

All Replies
  • Hello Stein,

    Is your user in the Master or in the tenant? [For the tenant zone you can specify the language during the tenant creation.]
    Once logged in, can you check the user's language from "My Profile > My Settings" ?

    Also, from My Localization Settings, check the DateFormat configured.
    Initially, I had been seeing only 04/21/2016, etc also for the Norwegian user. But once I changed the user-level setting to use the dot-separated date components, it worked for me. (It still needs to be understood why this step was needed).

    -Karthikeyan

  • DefaultLangCode and DefaultDateFormat are only used for new records when no language selection is made or available.

    It does not apply for existing users/tenants unless their language is not set.

    The possible values for DefaultDateFormat are:

    Value Format
    0 MM/dd/yyyy hh:mm a
    1 dd/MM/yyyy HH:mm
    2 dd.MM.yyyy HH:mm
    3 MM/dd/yyyy HH:mm
    4 yyyy-MM-dd HH:mm
    5 dd-MM-yyyy HH:mm
    6 yyyy/MM/dd HH:mm
    7 yyyy-MMM-dd HH:mm
    8 MM/dd/yyyy HH:mm:ss

    One thing is the way date and time are displayed, another is how the database stores these values.

    Internally, the database stores it as YYY-MM-DD hh:mm:ss Timezone (timestamp field).

  • Thank you, I changed this to '2' and get the correct date-format in my System-Console.

    But when I log in as 'Super-admin'/'Support' to one of my tenats, i get the english language (and dateformat) even if default language is 'no'.

    How can I get this correct??