[V4.0.4.0] - Workflow Action Button not rendered - Forum - Rollbase - Progress Community

[V4.0.4.0] - Workflow Action Button not rendered

 Forum

[V4.0.4.0] - Workflow Action Button not rendered

This question is not answered

Hello,

I have a workflow action button that was visible based on some condition and it works fine with the condition. However when I comment out the code and save the workflow action button configuration, the button is still not displayed. When I actually delete the code completely from the condition section, only then the workflow button is displayed. This seems like a bug to me and would like to know if someone can confirm this issue.

Cheers.

Iram

All Replies
  • Hi Iram,

    This is so because when you comment out the whole code, we evaluate the result of the condition as false in absence of any explicit return true. Thus, Action is not being rendered. There is a new functionality being introduced in 4.2 - a simple check-box (Enable Formula) on all such Boolean returning formula pages.

    So, in case your formulas is still not complete, you can keep on editing but just un-check the above check-box, before saving. This way, formula is not evaluated until you are ready for it.

    Thanks,

    Nitin

  • Hello Nitin,

    Thanks for that. That looks like a great enhancement and definitely would help us going forward. V4.2 gets more and more lucrative as we get closer to the release date. May I ask as to when exactly is V4.2 due to release?

    Cheers.

    Iram

  • Hi Iram,

    Glad you are excited about our upcoming release. Right now 4.2 is planned to release on Apr 30th (2016).

    Regards,

    Nitin

  • Iram,

    Please give it a try on the EAP instance to confirm it works as expected.

    Thierry.

  • Hello Thierry,

    Thanks for asking me to confirm it. Unfortunately it doesn't work as expected. When I check the "Enable Formula" I would expect the buttons not to be there using the formula given below but they are still shown:

    var currentRecord = {!id};
    
    if(currentRecord > 0)
    {
      return false;
    }
    else
    {
      return true;
    }

    Also the positioning of workflow actions has moved back to the dropdown list, however currently in 4.0.4 we have the workflow actions position next to the "Next", "Previous" and "Back to list" button. This is not where we were expecting it to be. This can be easily seen in the Default CRM application -> Cases -> View Page.

    Iram

  • Hello ,

    I have just updated to version 4.2 and I don't see the Enable Formula button anymore in this release. It is however still available in the EAP. I thought this was implemented a while ago?

    Iram

  • we did not release it in 4.2 due to issues in backward compatibility found while testing. We will roll it out in an upcoming release.

  • Is that going to V4.3? Any updates on the release date for that?

    Iram