New UI - Unique Field Combination & Integer Field - Forum - Rollbase - Progress Community

New UI - Unique Field Combination & Integer Field

 Forum

New UI - Unique Field Combination & Integer Field

This question is answered

Hi, 

I have a unique field combination trigger on an integer field. Basically I want this integer field to be unique but only when it is different from -1. This is why I am using unique field Combination with a condition.

It is working fine, but this is the error popup :

The error is shown twice, here 'My Error Message', and as you can see, there is also the integration name of the field (My-Integer_Field), which we don't want to show of course..

It is strange, I did this same test with another type of field and it is showing the error message normally.(not twice, and no integration name).

Any ideas?

Thank you

Meryem

Verified Answer
  • Hi,

    I quickly tried this and was able to reproduce.  This comes up only in case of inline editing.

    Logged bug (id:28686) for this

All Replies
  • Hello,

    Anything on this please?

    Meryem

  • Can you share a simple app xml where we can reproduce this ?

  • Sample App 2_v7.xml

    Here you are. 

    There are so many other stuff in this app but please just ignore all of it.

    Just look at object "ObjectEinss" and field "My Integer Field" in that same object. Try to change it to an existing value and you will get the error.

    Thank you,

    Meryem

  • Meryem, thank you for sharing app.

    Have run the same scenario & can confirm that I am getting only one 'My Error Message'.

    Have tried it out on the 4.0.4 beta release build.

    Can you please also validate against 4.0.4 Beta Release environment?

    Regards,
    Siraj.
  • Hi,

    I quickly tried this and was able to reproduce.  This comes up only in case of inline editing.

    Logged bug (id:28686) for this

  • This has been addressed for Rollbase 4.0.5 release.

    Regards,
    Siraj.
  • Good thanks.

    Meryem

  • Hello,

    Has this been fixed now in any of 4.1 or 4.2 please ?

    Thank you

    Meryem

  • yes it is working fine in 4.1

    Regards,

    Saras