Unable to obtain SQL data from SQL Server - Forum - Rollbase - Progress Community

Unable to obtain SQL data from SQL Server

 Forum

Unable to obtain SQL data from SQL Server

This question is not answered

Good day!

I am having a problem with extracting data from an external database. I have a userlist saved in SQL server 2008 R2 Express. I believe I was able to successfully configure the DataDirect Connectivity since I was able to extract data using the SQL test. My problem is that when I switch to progress rollbase, it won't extract the data from the data source. These are the sources which I based my configurations. Can anybody tell me where I went wrong?

Accessing External Data in Rollbase (references)

Results:

All Replies
  • Can you copy/paste the exact query from Rollbase into the DataDirect Cloud UI and see if it works?  I noticed the table name is quoted from Rollbase which can affect queries against case sensitive names.

    I'm also checking internally with the DataDirect Cloud team for any feedback.

    Check out my world famous blog on data connectivity

  • Hi -

    Can you please let us know what version of Rollbase you are using?

    -Regards

  • can you enable the check box highlighted below while creating D2C object. This is required when table or column names are case sensitive.

  • Please note that this flag is available only since 4.0.3 release. So, if you are on an older release, then you may have to upgrade to this one.

  • Hi Summit, 

    I tried doing what you said. It seems that the default in Rollbase is having those with quotation marks. When I did copy and paste to the DataDirect, it worked. 

  • Hi Manooj,

    I'm sorry, I am new to Rollbase and I can't find any info on where to find the version. I believe however that I am on the latest one since I recently tried creating the app and my rollbase account is about a month old. Can you tell me where to go to confirm?

  • Hi -

    The version info should be available in the subscription details page. You can reach it through the hamburger icon on the left top corner (if on New UI) or from the dropdown on the right top corner (user name) on classic UI.

    -Regards

  • Hi psaradhi,

    I deleted the object that wasn't working and made a new one with that option. No data is still reflecting the sql preview and the tab created for that.

  • Thanks Manooj,

    Found it. The system info shows Release 4.0.3.1

  • Hi -

    Do you see any errors in the logs? You can check by going to System Console App in the Master Tenant & Click on the System Tabs dropdown and select "Master Zone". From here you can view the logs for Master and other customers. Please go through the main.log file and see if you can figure out some exceptions.

    Otherwise, would you be able to provide us access to your datasource on data direct cloud so that I can connect to it from my private cloud instance and debug the issue?

    -Regards

  • Hi Manooj,

    I don't see any system console app. Is this for the Private servers? I am only using the cloud version and is in the trial period.

    As for access to the datasource, I have no problems with that. I used a sample SQL server. what do you need to connect? I will send it to you via private message.

    Regards

  • Hi -

    We have identified the issue and are working on a probable fix. Will keep you posted.

    Regards

  • Hi -

    We did observe an issue in the logs but are not able to replicate the issue using our data sources.

    Can you please share you D2C data source details via a private message ? I will need Username, password, datasource & table name that you have used in Rollbase to create the object.

    Regards

  • Hi,

    I think you are mapping some numeric type column (which holds more than 11 digits) to IntInput type in Rollbase. For such cases  please use DecimalInput instead of IntInput. By Default Decimal input has two decimal place,  which you can edit the field and set decimal places to 0.

    Thanks and Regards

    Pradeep