Rollbase Priivate Cloud installation - Forum - Rollbase - Progress Community

Rollbase Priivate Cloud installation

 Forum

Rollbase Priivate Cloud installation

  • Hi,

    I'm trying to setup new Rollbase Private Cloud test environment on my server.
    I'm using xampp package and it has apache/mysql/tomcat.

    I followed the installation process from the manual but now I'm getting the error like this:

    org.apache.jasper.JasperException: An exception occurred processing JSP page /login/header.jsp at line 22
    
    19: }
    20: Language lang = Language.getLanguage(langCode);
    21: 
    22: boolean isRollbase = (CompProps.getExternalURL("ROUTER").indexOf("rollbase.com") > 0) || (CompProps.getExternalURL("ROUTER").indexOf("rollbase.com") > 0);
    23: if (isRollbase) {
    24: 	int menu=11;
    25: %>

    Can anyone help please.

    Regards,
    MA

     

  • Some additional information:

    - PC has Windows 8.1 system.

    - I can get to the Tomcat welcome page.

    - and my java version is jre1.8.0_45

    Regards,

    MA

  • What Rollbase version are you using?

    try accessing this page http://<machinename>:<port>/router/login/loginPrivate.jsp

    Thanks

    Srinivas

  • Hi,

    Yes that is the page which is returning the error message.

    I'm using the latest version available to download from progress "try it" page, it is Rollbase v3.2.2.0 version.

    Regards,

    MA

  •  
    What version of Tomcat are you using?
     
     
    From: MaciejA [mailto:bounce-MaciejA@community.progress.com]
    Sent: Friday, June 05, 2015 7:24 AM
    To: TU.Rollbase@community.progress.com
    Subject: RE: [Technical Users - Rollbase] Rollbase Priivate Cloud installation
     
    Reply by MaciejA

    Hi,

    Yes that is the page which is returning the error message.

    I'm using the latest version available to download from progress "try it" page, it is Rollbase v3.2.2.0 version.

    Regards,

    MA

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi -

    Is the component.xml configured properly?

    -Regards,

    Manooj

  • Hi,

    @

    It is Tomcat 7.0.56.

    I didn't touch the component.xml file. It is as it was in the zip package.

    Regards,

    MA

  •  
    Can you try with a version 1.7 JRE?
     
    Thanks,
    Tom
     
     
    From: MaciejA [mailto:bounce-MaciejA@community.progress.com]
    Sent: Friday, June 05, 2015 8:44 AM
    To: TU.Rollbase@community.progress.com
    Subject: RE: [Technical Users - Rollbase] Rollbase Priivate Cloud installation
     
    Reply by MaciejA

    Hi,

    @Tom Kincaid

    It is Tomcat 7.0.56.

    Manooj Murali

    I didn't touch the component.xml file. It is as it was in the zip package.

    Regards,

    MA

    Stop receiving emails on this subject.

    Flag this post as spam/abuse.

  • Hi,

    Now I'm getting this error:

    com.rb.util.core.a147: Cannot find component ROUTER. Please check components.xml configuration file

    What I should change in the component.xml?

    Regards,

    MA

  • Can you please check if there is a Router component in the components.xml?

  • <Component name="ROUTER" type="ROUTER">

    <DisplayName>Router Server</DisplayName>

    <InternalRoot>http://localhost:8080/router/</InternalRoot>

    <ExternalRoot>http://{!#HOST_NAME}/router/</ExternalRoot>

    <Props>

    <StatusCheckInterval>10</StatusCheckInterval>

    <CustWeight>3</CustWeight>

    <CleckLoginURL>true</CleckLoginURL>

    </Props>

    </Component>

  • Hi,

    I tried java 1.7 and also used components.xml from our live server.

    Unfortunately nothing worked :(

    Any other suggestions? Much appreciated.

    Thank you,

    Regards,

    MA

  • Hi MaciejA,

    Did you configure your shared.properties file?

  • Hi Ricardo,

    Everything is working under the localhost what is the default configuration. I added port numbers and email details.

    That is it. I also have compared that file with the shared.properties on our live server.

    Regards,

    MA  

  • Hi MaciejA,
     
    I have created a doc file showing step by step how I have installed XAMPP and Rollbase 3.2.2 .
    Here is the file: 
    XAMPPwithRollbase.docx
     
    It is running with:
    Tomcat 7.0.56
    jre1.8.0_45
    mysql 5.6
     
    Regards,
    Ricardo