Related Field between two OE objects not working - Forum - Rollbase - Progress Community

Related Field between two OE objects not working

 Forum

Related Field between two OE objects not working

This question is not answered

I have a one to many relationship from a OE customer object and a OE bill-to object. Can anyone tell me if adding a related field on the bill-to object to get a value from the customer object is fully supported? I can add the field but it doesn't display anything so I was wondering if it's a known bug or just in BETA. I can create a formula field as a work around if needed.

Thanks

All Replies
  • Could you please post the steps performed and the screenshots for better understanding ? Which rollbase version are you using?

  • The version is 3.0.5.0.

    For steps (there really isn't much for screen shots):

    Have two open edge objects with a one to many relationship (one customer to many bill-tos)

    From the customer bill-to object, create a new field and select the 'Related Field' option

    Change the Related Object option to customer and select any field you know is always populated

    Add the field to the view page but when displaying the bill-to, the related customer field is not populated.

  • OK. So, I tried this out on the 3.1 (recently out) release and it seems to be working fine.

    1. Created two objects with one(Customer)-many(BitllTo) relationship.

    2. Created Related Field ('relatedField') in BillTo object and added it to view page.

    3. Create customer 'one'.

    4. Created BillTo and associated it with customer 'one'.

    Now, when I view the BillTo record, the related field is populated.

    Can you try this out on the 3.1 release?

    -Regards.

  • I have some projects that use relationships between OpenEdge Service Objects and I found that this works more smoothly in 3.1. I don't know for sure if anything was done for your particular scenario, but I have seen improvement in many corner cases in OpenEdge Service Object relationships. =