Query API problems - Forum - Rollbase - Progress Community

Query API problems

 Forum

Query API problems

  • hello,

      I create trigger with a this query:

    var res = rbv_api.selectQuery("SELECT language,id,R12756,manager_id FROM USER Where id='19995'", 1);

    in adminstrateur user this trigger work perfectly

    but in other user  the res.length is always = 0.

    I have check all checkbox in permission (api and role) .

    I don't understand why?

      

  • Please make sure that current user (or Query API role) has permission to view USER records.

  • in role permission of my user Users section have all checked, in quert api role User serction All checked,

    i have forgottend something?

  • Hi adrien,

    Can you see the Object Attributes of user object if the Organization was checked?
    If you are not using Organization Management app try to uncheck that attribute.

    Regards,
    Orchid
  • In my user attribut Organization Management is check , i uncheck this , but i have same result

  • Hi adrien,

    Have you run the trigger after unchecking the Organization attribute?

    Regards,
    Orchid
  • I try it , but in adminitrator role is work , but when a create a new record , my trigger don't work because my query return 0 record.

  • Is this a delayed trigger ?

  • no

  • Hi adrien,

    I have verified this scenario and RB 3.0 and and it worked fine for me

    I belive this issue is fixed in RB 3.0 which will be available soon.

    steps followed :

    1.logged in as FIrst admin in rollbase private cloud

    2.Created an application and objects

    3. Created an after update object script trigger , used selectquery() API in it

    4. Verified that trigger worked for administrator user

    5. Create a custom role 'test' and assigned this role to the application created above. (in object definition marked all query api permissions on this object and gave alll permissions to this role )

    6. created a user 'A' and assigned the role 'test'

    7. login as user 'A' and observer the application is accessiable to this user

    8. Create and update a record and observe that Trigger get executed successfully.

    please let me know if this the correct scenario that your trying to do.

    Thanks,

    Sharavan

  • Yes is correct scenario , but have try a slectquery on USER ? or other object? because for other object is work just USER return nothing. it's work for admin role

  • I try with getfieldvalue is work , i thinks is a another bug, i wait Rollbase 3.0 for testing this issue

  • Please try using "Test Query" Debugger (use button next to "Debug Formula"

  • in admin is work , in other role use how to debug?

  • Good point. Perhaps we should enhance Debuggers and run them as different user.