XLS reader is not installed on this system error - Forum - Rollbase - Progress Community

XLS reader is not installed on this system error

 Forum

XLS reader is not installed on this system error

This question is answered

On private cloud i am getting this message "XLS reader is not installed on this system" when i try to do batch job ftp import. How do i fix this?

Verified Answer
  • This may be your issue: Rollbase uses JExcel API to read, write, and manipulate Excel 2003 spreadsheets in XLS format. Although this API is free, Rollbase does not include it into Private Cloud binaries for legal reasons.

    Could this be your issue?  Have you downloaded this component?

    For more on this see Rollbase in Action: Chapter 18: Installing and Configuring Private Cloud

    (or the online/HTML version HERE)

All Replies
  • Mr. Dagesse,



    I have referred your issue to our Rollbase engineers and other colleagues, I will be sure to reply with updates once any are available. Please feel free to reply with any useful information that may better describe the issue.



    Thanks,

    Corey Prak
  • Hi Chris,



    I created case # 77089484 - "XLS reader is not installed on this system error" to follow on this issue,



    Can you please attach the complete rollbase logs to this case for Support investigation.



    Thank You,

    Srikanth

    Progress|Rollbase Product Support Team

  • where do i find those ?
  • Hi Chris,



    You should be able to find the logs under $ROLLBASE_HOME/storage

    Please zip and attach to the case # 77089484 for Support investigation.



    Thank You,

    Srikanth

    Progress|Rollbase Product Support Team
  • Hi,

    Is there a feedback on this issue?

    I have a 'XLS writer not installed’ error when trying to download the translation spreadsheet for update.

    Thank you,

    Mihai

  • This may be your issue: Rollbase uses JExcel API to read, write, and manipulate Excel 2003 spreadsheets in XLS format. Although this API is free, Rollbase does not include it into Private Cloud binaries for legal reasons.

    Could this be your issue?  Have you downloaded this component?

    For more on this see Rollbase in Action: Chapter 18: Installing and Configuring Private Cloud

    (or the online/HTML version HERE)

  • Thank you Bill, this solved my issue.

  • That is good.  For the record, please note the other items in Chapter 18 that you might need if you want to create, for example, PDF files, or Word documents (or use different charts).