App Install Problem - Forum - Rollbase - Progress Community

App Install Problem

 Forum

App Install Problem

  • When I try to install an app from my Master Zone, into Customer Zones, I receive a message indicating that two templates are not found. The message is as follows: Template 72314 not found Template 72593 not found However, both templates are in the Master Zone and seem to be working fine. In fact, both templates are already installed in the Customer Zone... in that they are associated with an Object which is shared by the app I'm trying to install and an app already installed. What am I missing/what should I check for? -Mike
  • Please submit support request on rollbase.com and attach your application XML.



    Where these templates are used?
  • They are conversion/data map templates... i.e. each is used by a trigger to convert one object to another.



    I just tried deleting and re-creating the templates in Master Zone. That didn't help.



    Now I'm going to try un-installing/deleting the apps in the Customer Zones and then re-installing the apps from the Master Zone.



    As you requested... I'll submit a ticket, after I have diag'd a little more.



    Thanks
  • Do you include both source and destination conversion objects in your app?



    I should take a look and check if I can reproduce the issue.
  • Could you generate XML from your app?
  • I will when I get back online... it will be an hour or two from now.
  • OK... it's all very confusing.



    By changing which Objects were "core" and which were "dependent," I was able to get the 2nd app to install after I installed the first app. I'm really not sure what's "core" and what's "dependent," when/why RB decides to reclassify how I have Objects set (re "core" and dependent... and a number of other questions. I'll submit "tickets" and XML as you requested, as soon as I can.



    In addition to what's above, I now have a different problem.



    If the apps are flagged as "managed," I can't install updates in Customer Zones. Why I try to install updates... it just "hangs," with the "loading, please wait" message flashing... forever.



    How can I figure out why it is hanging when I try to install updates relating to "managed apps?"



    -Mike
  • It's not Rollbase decides, it's you decide when you edit your app.



    I will fix error message.
  • No... when I save, Rollbase changes how I have the Objects classified. That is... even though I set certain Objects to "Core" and others to "Dependent," when I save the app record my classifications are changed.



    When I get a chance, I'll submit tickets for all of this... but, just so you know, I'm also receiving messages like the following:



    java.lang.NullPointerException

    at com.rb.core.ui.web.a323.deletePage(a323.java:421)

    at com.rb.core.ui.web.a323.delete(a323.java:390)

    at p0.a38.createPage(a38.java:757)

    at p0.a38.createPageDef(a38.java:737)

    at p0.a38.install(a38.java:242)

    at p0.a38.install(a38.java:165)

    at p5.a128$PacketUpdateJob.doJob(a128.java:301)

    at com.rb.util.system.a452.run(a452.java:143)



    and



    java.lang.NullPointerException

    at com.rb.core.ui.web.a323.deletePage(a323.java:421)

    at com.rb.core.ui.web.a323.delete(a323.java:390)

    at p0.a38.createPage(a38.java:757)

    at p0.a38.createPageDef(a38.java:737)

    at p0.a38.install(a38.java:24
  • Looks like a bug, will be fixed ASAP.



    It would be helpful if you could submit your application XML.
  • This is fixed now.
  • Thanks... I no longer receive the "exceptions." However, I still don't understand why RB changes how I set an app's "core" and "dependent" objects. Is the following what you intend RB to be doing?



    1) I set an app's "Core" objects to be "A" its "Dependent" objects to be "B," "C," "D," and "E."



    2) I "Save" the app record and do not receive any sort of "error message."



    3) I Open the app record and RB displays "Core" and "Dependent" object settings which differ from what I set in step 1 above.



    4) I install the app in a Customer Zone... and the app record in that Customer Zone is different than the settings in step 1 and 3 above. Once again, RB has decided (based on something) which objects are "Core" and which are "Dependent."



    Please explain what I should be "expecting?" What is RB's intended behavior?
  • I will document algorithm which calculates set of core and dependent objects.