Access of Setting object always returns a error in portal - Forum - Rollbase - Progress Community

Access of Setting object always returns a error in portal

 Forum

Access of Setting object always returns a error in portal

  • I am having problems with accessing fields from the setting object from a portal. I've enabled the portal visitor access to this object and still i get an error. Is there a special setting for the settings object to make it a available for the portal? Thanks.
  • What exactly do you mean by "accessing" ? You can use Settings as template tokens, I believe.
  • I created a formula field in the settings object and enabled all permissions to the object, including portal visitor. Unfortunately when I use the template tokens, instead of giving me the value it computed for, it gives me

    "ERROR: Error You do not have permission to perform this action (line #4) in formula:
    341var rbv_api = new Packages.com.rb.core.services.api.ServerSideAPI(52358415, -1"
  • Please give View access to your object for "Query API" role.
  • Yes my object has this view access already, but still displays the error. Here's a similar error that we encountered. The first screenshot is from the portal side and the other is the permissions of the object.
  • Hi Simone,

    API on portal side works fine for my test environment. If you want me to help you further I'll need to look into your zone. There is nothing I can say at a moment.
  • You have clear references on line number (#4, #5) but you're not telling me what's on these lines. That would be helpful.