rbv_api.runtrigger returns ERROR: Error Wrapped java.lang.NullPointerException - Forum - Rollbase - Progress Community

rbv_api.runtrigger returns ERROR: Error Wrapped java.lang.NullPointerException

 Forum

rbv_api.runtrigger returns ERROR: Error Wrapped java.lang.NullPointerException

  • Hi Pavel, I'm having a problem with rbv_api.runTrigger. It doesn't appear that the trigger is being executed. I am getting an error when I debug the trigger formula and debug all triggers after an update similar to this:
    
       Checking trigger: UPDATE TEST FIELD (TESTING--Mike) (ID=13829787)
    
      Running UPDATE TEST FIELD (TESTING--Mike) on Building: Building (ID=13825820)
    
      ERROR: Error Wrapped java.lang.NullPointerException (line #5) in formula:
    
    var rbv_api = new Packages.com.rb.core.services.api.ServerSideAPI(3668658, 6258428);
    
    
    
    rbv_api.setVerbose(true);
    
    
    
    rbv_api.runTrigger("cpa_project", 13825819, "UPDATE_TEST");
    
      DEBUGGING INFO:
    
    Running trigger UPDATE TEST FIELD (TESTING -MIKE) on 47245
    
    
    
    ===============================
    
    Finished ON_AFTER_UPDATE on Building (ID=13825820)
    
    
    It says that the UPDATE TEST FIELD trigger is running, but it doesn't look like it is. The Field does not get updated and there is no log displaying the results of the trigger (ie. Changing Test Field to 500
  • In the log, both of the triggers are named "UPDATE TEST FIELD" - the first one contains the rbv_api.runTriggers() code. The second one says it's Running trigger (in the debug log) but it doesn't really seem to run. Hopefully that's not too confusing.
  • Please submit support request from your zone to follow up.